Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
nvidia linux tester wanted
#41
of course if anyone else is able to do this test while i am unavailable then go right ahead. Smile
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply

Sponsored links

#42
I tried to apply the patches in your last post and it doesn't succeed...

Code:
[email protected] ~/testing/piglit $ git am 0001-piglit-util-new-functions-piglit_program_pipeline_ch.patch
Applying: piglit util: new functions piglit_program_pipeline_check_status/quiet
error: patch failed: tests/util/piglit-shader.h:36
error: tests/util/piglit-shader.h: patch does not apply
Patch failed at 0001 piglit util: new functions piglit_program_pipeline_check_status/quiet

Am I missing something here?
Reply
#43
Was it a clean git repository? up to date?
Reply
#44
Yep, I cloned it a few minutes ago. Is it possible they've changed that file since? All the patches other than 0001 apply, but that one is rather critical so it isn't much use without it.

EDIT: Found the issue, a line is there taht your patch isn't expecting:
Code:
GLint piglit_build_simple_program(const char *vs_source, const char *fs_source);
Reply
#45
Test results attached (they were run in order as listed in the original thread post).

OpenGL renderer string: GeForce GTX 660 Ti/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 319.17
Reply
#46
Additionally I've done as mentioned here (http://forums.pcsx2.net/Thread-nvidia-li...#pid290384) and replaced that with break and then used the script you provided to run the tests in the latest post. The result was as follows...

Code:
******** RUN arb_separate_shader_object-GetProgramPipelineiv
Attach program (2) to stage (GL_VERTEX_SHADER). Expected to be supported: yes
Attach program (1) to stage (GL_FRAGMENT_SHADER). Expected to be supported: yes
Attach program (0) to stage (GL_GEOMETRY_SHADER). Expected to be supported: yes
Attach program (0) to stage (GL_TESS_EVALUATION_SHADER). Expected to be supported: yes
Attach program (0) to stage (GL_TESS_CONTROL_SHADER). Expected to be supported: yes
PIGLIT: {'result': 'pass' }
******** RUN arb_separate_shader_object-IsProgramPipeline
glGenProgramPipelines with negative n value
glGenProgramPipelines with correct n value
Pipeline 1 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 2 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 3 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 4 has wrong IsProgramPipeline. Expected 0, got 1
./runtest.sh: line 11: 17575 Segmentation fault      (core dumped) ./$sso_test -auto
******** RUN arb_separate_shader_object-mix_pipeline_useprogram
TEST 1
Enable monolithic program
Bind pipeline
Failed to get GL_PROGRAM_PIPELINE_BINDING expected 1 got 0
Probe at (0,0)
  Expected: 1.000000 0.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
PIGLIT:subtest {'TEST_1' : 'fail'}
TEST 2
Disable monolithic program
Bind pipeline
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
PIGLIT:subtest {'TEST_2' : 'fail'}
TEST 3
Enable monolithic program
Failed to get GL_PROGRAM_PIPELINE_BINDING expected 1 got 0
PIGLIT:subtest {'TEST_3' : 'fail'}
Probe at (0,0)
  Expected: 1.000000 0.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
TEST 4
Disable monolithic program
Bind pipeline
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
Disable monolithic program
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
Bind pipeline
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
PIGLIT:subtest {'TEST_4' : 'fail'}
TEST 5
Disable monolithic program
Bind pipeline
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
Enable monolithic program
Disable monolithic program
Probe at (0,0)
  Expected: 0.000000 1.000000 1.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
Bind pipeline
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
PIGLIT:subtest {'TEST_5' : 'fail'}
TEST 6
Disable monolithic program
Unbind pipeline
Probe at (0,0)
  Expected: 0.000000 0.000000 1.000000 1.000000
  Observed: 0.525490 0.619608 0.709804 1.000000
PIGLIT:subtest {'TEST_6' : 'fail'}
PIGLIT: {'result': 'fail' }
******** RUN arb_separate_shader_object-ValidateProgramPipeline
Failed to compile geometry shader: 0(8) : error C7566: in blocks require #version 150 or later
0(8) : error C0000: ... or #extension GL_ARB_gpu_shader5 : enable
0(14) : error C7566: out blocks require #version 150 or later
0(14) : error C0000: ... or #extension GL_ARB_gpu_shader5 : enable
0(16) : error C0000: syntax error, unexpected '(', expecting "::" at token "("
0(21) : error C7532: global function EmitVertex requires "#version 150" or later
0(21) : error C0000: ... or #extension GL_EXT_geometry_shader4 : enable
0(23) : error C7532: global function EndPrimitive requires "#version 150" or later
0(23) : error C0000: ... or #extension GL_EXT_geometry_shader4 : enable

Failed to compile error shader: 0(17) : error C0000: syntax error, unexpected '(', expecting "::" at token "("

Failed to compile error shader: 0(17) : error C0000: syntax error, unexpected '(', expecting "::" at token "("

Failed to link: Link info
---------
No shader objects attached.
Failed to link: Link info
---------
No shader objects attached.
Failed to link: Link info
---------
No shader objects attached.
Failed to link: Link info
---------
No shader objects attached.
PIGLIT: {'result': 'fail' }
******** RUN useprogstage_noactive
Transform feedback not supported.
PIGLIT: {'result': 'skip' }
******** RUN useprogstage_active
Transform feedback not supported.
PIGLIT: {'result': 'skip' }
******** RUN bind_pipeline
Transform feedback not supported.
PIGLIT: {'result': 'skip' }


... which doesn't look all that great...
Reply
#47
you got an issue with waffle. Either use git version of waffle or replace it with glut (you could hack cmake).
Reply
#48
see page 3 of this thread about what i had to do to hack cmake to make waffle cooperate - thanks gregory Smile .
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#49
Yeah, just spotted it Tongue

Code:
******** RUN arb_separate_shader_object-GetProgramPipelineiv
Attach program (5) to stage (GL_VERTEX_SHADER). Expected to be supported: yes
Attach program (4) to stage (GL_FRAGMENT_SHADER). Expected to be supported: yes
Attach program (3) to stage (GL_GEOMETRY_SHADER). Expected to be supported: yes
Attach program (2) to stage (GL_TESS_EVALUATION_SHADER). Expected to be supported: yes
Attach program (1) to stage (GL_TESS_CONTROL_SHADER). Expected to be supported: yes
PIGLIT: {'result': 'pass' }
******** RUN arb_separate_shader_object-IsProgramPipeline
glGenProgramPipelines with negative n value
glGenProgramPipelines with correct n value
Pipeline 1 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 2 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 3 has wrong IsProgramPipeline. Expected 0, got 1
Pipeline 4 has wrong IsProgramPipeline. Expected 0, got 1
./runtest.sh: line 11: 18989 Segmentation fault      (core dumped) ./$sso_test -auto
******** RUN arb_separate_shader_object-mix_pipeline_useprogram
Failed to compile vertex shader: 0(11) : error C7533: global variable gl_Vertex is deprecated after version 120

Failed to link: Link info
---------
No shader objects attached.
Failed to link: Link info
---------
No shader objects attached.
Unexpected GL error: GL_INVALID_VALUE 0x501
(Error at /home/arcade/testing/piglit/tests/spec/arb_separate_shader_objects/mix_pipeline_useprogram.c:377)
Unexpected GL error: GL_INVALID_OPERATION 0x502
(Error at /home/arcade/testing/piglit/tests/spec/arb_separate_shader_objects/mix_pipeline_useprogram.c:108)
TEST 1
Enable monolithic program
Bind pipeline
Failed to get GL_PROGRAM_PIPELINE_BINDING expected 1 got 0
PIGLIT:subtest {'TEST_1' : 'fail'}
TEST 2
Disable monolithic program
Bind pipeline
PIGLIT:subtest {'TEST_2' : 'pass'}
TEST 3
Enable monolithic program
Failed to get GL_PROGRAM_PIPELINE_BINDING expected 1 got 0
PIGLIT:subtest {'TEST_3' : 'fail'}
TEST 4
Disable monolithic program
Bind pipeline
Disable monolithic program
Bind pipeline
PIGLIT:subtest {'TEST_4' : 'pass'}
TEST 5
Disable monolithic program
Bind pipeline
Enable monolithic program
Disable monolithic program
Bind pipeline
PIGLIT:subtest {'TEST_5' : 'pass'}
TEST 6
Disable monolithic program
Unbind pipeline
PIGLIT:subtest {'TEST_6' : 'pass'}
PIGLIT: {'result': 'fail' }
******** RUN arb_separate_shader_object-ValidateProgramPipeline
INFO: ALL stages supported: running all test
TEST 1: sanity check prog_vs_fs
PIGLIT:subtest {'TEST_01' : 'pass'}
TEST 2: bad: prog_gs in the middle of prog_vs_fs
Failed to validate the pipeline: error: Program object is active for a stage between two stages for which another program object is active
PIGLIT:subtest {'TEST_02' : 'pass'}
TEST 3: bad: prog_fs and only VS of prog_vs_fs
Failed to validate the pipeline: error: Program object is not active for all stages for which it contains executable code
PIGLIT:subtest {'TEST_03' : 'pass'}
TEST 4: good: prog_vs_fs in 2 step
PIGLIT:subtest {'TEST_04' : 'pass'}
TEST 5: bad: prog_gs without prog_vs
Failed to validate the pipeline: error: Program pipeline object contains an active geometry program, but no active vertex program
PIGLIT:subtest {'TEST_05' : 'pass'}
TEST 6: bad: only GS of prog_vs_gs
!!! Wrong pipeline validation status. Got 1, expected 0

PIGLIT:subtest {'TEST_06' : 'fail'}
TEST 7: good: sanity check all single prog
PIGLIT:subtest {'TEST_07' : 'pass'}
TEST 8: bad: prog_tcs in the middle of prog_vs_gs
Failed to validate the pipeline: error: Program object is active for a stage between two stages for which another program object is active
PIGLIT:subtest {'TEST_08' : 'pass'}
TEST 9: bad: prog_tes in the middle of prog_vs_gs
Failed to validate the pipeline: error: Program object is active for a stage between two stages for which another program object is active
PIGLIT:subtest {'TEST_09' : 'pass'}
TEST 10: bad: only tes of prog_tess
!!! Wrong pipeline validation status. Got 1, expected 0

PIGLIT:subtest {'TEST_10' : 'fail'}
TEST 11: bad: prog_tess without prog_vs
Failed to validate the pipeline: error: Program pipeline object contains an active tesselation control program, but no active vertex program
error: Program pipeline object contains an active tesselation evaluation program, but no active vertex program
PIGLIT:subtest {'TEST_11' : 'pass'}
TEST 12: bad: relink attached prog_fs without GL_PROGRAM_SEPARABLE
PIGLIT:subtest {'TEST_12a' : 'pass'}
!!! Wrong pipeline validation status. Got 1, expected 0

PIGLIT:subtest {'TEST_12b' : 'fail'}
PIGLIT: {'result': 'fail' }
******** RUN useprogstage_noactive
MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTIBS=4
Compile vertex shader
Setup transform feedback for 1 varyings in interleaved mode
Link program
Create 2nd program for the pipeline
Use pipeline
Prepare 1 buffers
BindBufferBase(buffer 0)
BeginTransformFeedback
Use new program stage
PIGLIT: {'result': 'pass' }
******** RUN useprogstage_active
MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTIBS=4
Compile vertex shader
Setup transform feedback for 1 varyings in interleaved mode
Link program
Create 2nd program for the pipeline
Use pipeline
Prepare 1 buffers
BindBufferBase(buffer 0)
BeginTransformFeedback
Use new program stage
PIGLIT: {'result': 'pass' }
******** RUN bind_pipeline
MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTIBS=4
Compile vertex shader
Setup transform feedback for 1 varyings in interleaved mode
Link program
Create 2nd program for the pipeline
Use pipeline
Prepare 1 buffers
BindBufferBase(buffer 0)
BeginTransformFeedback
Bind a new pipeline
PIGLIT: {'result': 'pass' }
Reply
#50
Thanks. I will need to fix some stuff in 1 tests....

Edit could you add this new patch. Let's hope it fix bin/arb_separate_shader_object-mix_pipeline_useprogram on nvidia.
Reply




Users browsing this thread: 1 Guest(s)