Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2-0.9.8 on fedora 15 problem
#1
Greetings programs! Smile
While trying to launch binary pcsx2-0.9.8 on fedora 15 i get the following error:

[[email protected] pcsx2-0.9.8-r4594-linux]# ./launch_pcsx2_linux.sh
./pcsx2: Symbol `_ZTV10wxClientDC' has different size in shared object, consider re-linking
./pcsx2: Symbol `_ZTV10wxMemoryDC' has different size in shared object, consider re-linking
./pcsx2: Symbol `_ZTV9wxPaintDC' has different size in shared object, consider re-linking
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
./launch_pcsx2_linux.sh: line 27: 2124 Aborted (core dumped) ./pcsx2
[[email protected] pcsx2-0.9.8-r4594-linux]#

my system is:
[[email protected] pcsx2-0.9.8-r4594-linux]# uname -a
Linux miki 2.6.38.7-30.fc15.i686.PAE #1 SMP Fri May 27 05:44:56 UTC 2011 i686 i686 i386 GNU/Linux

I was trying to compile from pcsx2-0.9.8-r4600-sources but i have got the following:

[[email protected] my_build]# cmake ../CMakeLists.txt "-DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_STRIP=FALSE"
-- Disable the stripping by default in Release -DCMAKE_BUILD_STRIP=FALSE build !!!
-- Use internal version of Soundtouch by default.
Note: There have been issues in the past with sound quality depending on the version of Soundtouch
Use -DFORCE_INTERNAL_SOUNDTOUCH=FALSE at your own risk
-- Install localization file in bin/Langs by default
-- Could NOT find GLEW (missing: GLEW_LIBRARY GLEW_INCLUDE_DIR)
-- Use internal pcsx2 SoundTouch library
-- Skip build of GSdx: miss some dependencies
-- check these libraries -> opengl, X11, pcsx2 SDL
-- Skip build of zerogs: miss some dependencies
-- check these libraries -> glew (>=1.5), opengl, X11, nvidia-cg-toolkit (>=2.1)
-- Skip build of zzogl: miss some dependencies
-- check these libraries -> glew (>=1.5), jpeg (>=6.2), opengl, X11, nvidia-cg-toolkit (>=2.1), pcsx2 common libs
CMake Error at CMakeLists.txt:57 (TARGET_LINK_LIBRARIES):
Cannot specify link libraries for target "x86emitter" which is not built by
this project.


-- Configuring incomplete, errors occurred!


Please help!
Reply

Sponsored links

#2
Hi, yes you need to compile on fedora. If you compile better take trunk instead of 0.9.8

Do you have libglew installed, 1.5 or 1.6 ? Technically it must work with 1.6 but cmake might need some update.
Reply
#3
Thanks for swift response!
I've got libGLEW-1.5.8-3.fc15.i686
I am on getting and compiling trunk

(06-27-2011, 08:55 PM)gregory Wrote: Hi, yes you need to compile on fedora. If you compile better take trunk instead of 0.9.8

Do you have libglew installed, 1.5 or 1.6 ? Technically it must work with 1.6 but cmake might need some update.

Reply
#4
I guess I need to checkout current version using subversion? Could you provide url or better - the whole command? I am not familiar with svn.


(06-27-2011, 08:55 PM)gregory Wrote: Hi, yes you need to compile on fedora. If you compile better take trunk instead of 0.9.8

Do you have libglew installed, 1.5 or 1.6 ? Technically it must work with 1.6 but cmake might need some update.

Reply
#5
Maybe you miss the -dev package! Fedora 14 have those 2 packges glew.i686 glew-devel.i686

svn checkout http://pcsx2.googlecode.com/svn/trunk/ pcsx2-read-only
Reply
#6
... Checked out revision 4778. (thanks !)
in the matter of fact I had no glew-devel.
Now I have:
libGLEW-1.5.8-3.fc15.i686
glew-devel-1.5.8-3.fc15.i686
libGLEWmx-1.5.8-3.fc15.i686


but still getting errors during cmake:

CMake Error at pcsx2/CMakeLists.txt:662 (target_link_libraries):
Attempt to add link library "x86emitter" to target "Utilities" which is not
built in this directory.

CMake Error at pcsx2/CMakeLists.txt:665 (target_link_libraries):
Cannot specify link libraries for target "-pthread" which is not built by
this project.

-- Configuring incomplete, errors occurred!
Reply
#7
The critical error is this one:
-- Could NOT find GLEW (missing: GLEW_LIBRARY GLEW_INCLUDE_DIR)
Do you still have it? In my opinion you did not install the devel package of libglew (something like that glew-devel-1.5.8-3.fc15.i686.rpm)

Edit: try also to call cmake without quote. Note, use default option for CMAKE_BUILD_STRIP it is the best Wink
cmake ../CMakeLists.txt -DCMAKE_BUILD_TYPE=Release
Reply
#8
I have run ldconfig than -
cmake ../CMakeLists.txt -DCMAKE_BUILD_TYPE=Release
and it worked.

Thanks a lot!
Reply




Users browsing this thread: 1 Guest(s)