Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2 1.40 constantly running at ~50% speed
#1
Hi guys, just putting this out in case anyone had a similar problem and know what the issue is.

Been playing Wild Arms 5 for a while and it's been working properly.

A few days ago its speed started to drop upon boo tup and immediately becomes constant between 40 - 50%, turbo or slowmo is not enable.
Tried other games experiencing the issue and the speed is the same now for all games am loading.

Didn't make any changes to the pcsx2 configs, and am not sure if it's due to my video card, though I can still play other games which have high 3D requirements properly.

Any help is greatly appreciated, thanks all!

Laptop specs:
-- Processor Intel® Core™ i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)
-- (RAM) 16.0 GB
-- NVIDIA GeForce GTX 970M

I can't post my emuLog.txt unfortunately, the site keeps blocking me, even if I attach it. Sad
Reply

Sponsored links

#2
Update to the latest version of PCSX2, version 1.4 is super old.
-PC Specs-
AMD Ryzen 3600
16gb DDR4 Corsair 3200mhz
MSI Armor Radeon RX580 8gb 
Dell 27" LED
Windows 10 Pro x64 
-Laptop Specs-
i7 6700HQ @ 2.9Ghz
8gb DDR3 
GTX 960m 4GB
Windows 10 Pro x64
Reply
#3
I tried running 1.50 and even 1.70 unfortunately am encountering the same result, which makes me think that it's due to my video card.
But then again I am able to play other PC games which are a bit 3D intensive.

My global display settings is already set to use may primary NVIDIA display for PCSX2 instead of the generic Intel graphics adapter.
Reply
#4
Did you set Windows power plan to performance mode ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Do you mean 40fps

Go to the nvidia control panel=>manage 3d settings=>program settings=>uncheck "show only programs found on this computer"=>look for pcsx2 in the drop down list and once you find it and select it and from the options below set
Maximum frame rate to off
Whisper mode to 120 fps
Turbo mode and f4(removing the fps limit in pcsx2)will be limited to 120fps
If you want to run games at more than 120fps,you will have to disable whisper mode which can be enabled\disabled in annoying way

Whisper mode is enabled by default on laptops and to be able to disable it,you will need nVidia Experience installed and create an account or use your google account to be able to disable it
Reply
#6
Thumbs Down 
Thanks for the responses guys.

The speed is showing as 50% then followed by (30) which I'm assuming is showing the FPS.
-- windows battery setting is set to best performance.
-- Maximum frame rate to off > don't seem to have this in my nvidia settings
-- Whisper mode to 120 fps > this one specifically says not applicable to my card in the nvidia exp
-- Turbo mode and f4(removing the fps limit in pcsx2)will be limited to 120fps > tried turbo mode + removing the fps limit and no changes, speed remained at 50
-- disabled battery boost in nvidia exp which seems to be all about capping performance at 30 fps if on battery just in case, but still no changes observed in the performance

My emu log seems to say am using a 59.94 fps limit, but what a mystery that it seems to be limiting it to 30.
Can't post the entire log but here are the last few lines.

Just my luck, am not sure if any video card settings have been accidentally changed, cause it was working fine just the other day.

Code:
Number  :SLUS-21615
Version :100
VMode   :NTSC
Language:ENGLISH
Warning :NO
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...
Reply
#7
Try pressing F4,Tab or Shift+Tab
In the game window title bar,what does "Limiter:" says
Reply
#8
Make also sure you have turned off vsync in nvidia panel and pcsx2
Reply




Users browsing this thread: 1 Guest(s)