pcsx2 64 bit - audio works but screen stays black
Hello, this is my first experience with pcsx2. My OS is ubuntu precise 64 bit.
I tried FFX game with the following pcsx2 source:
1. pcsx2 1.0 linux binary downloaded from pcsx2.net download page
2. pcsx2 1.0 unstable linux binary downloaded from ppa
3. pcsx2 1.0 windows binary downloaded from pcsx2.net download page run with wine

When running pcsx2 1.0 linux binary (1) and (2), the display from beginning didn't showed up, only a black screen, but I know the game is running because I heard the sound.
When running pcsx2 1.0 windows binary with wine, everything is running properly, the display, the sound, everything is good.

And also I've tried running the game directly from the dvd and the iso. The result is same, linux binary could not showing the graphic.

I wondered if I have to install some driver to my linux box. Thanks for the help.

My Graphic adapter
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Elitegroup Computer Systems Device 9981
    Flags: bus master, fast devsel, latency 0, IRQ 43
    Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 1800 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

Sponsored links

FBO's are required, which Intel HD doesn't do very well.
Only the following intel GPU are "supported": sandy bridge and ivy bridge. Fo gsdx, you will also need a feature-complete drivers which intel doesn't have yet.
that is a sandybridge igp
might need to update his intel driver package :<
ok, I'm updating my driver now. thanks.
According to intellinuxgraphics.org, the "latest" driver is:
Kernel: Linux 3.4.x release
3D driver: mesa 8.0.4 release
2D driver: xf86-video-intel 2.20.0 release
Libdrm: libdrm-2.4.37 release
Libva: libva-1.0.15 release
Vaapi-driver-intel: vaapi-driver-intel-1.0.17 release
Cairo: cairo 1.12.2 release

After I updated my driver from here, my driver looks like
Kernel: Linux 3.5.x release
3D driver: mesa 9.0 release
2D driver: xf86-video-intel 2.20.5 release
Libdrm: libdrm-2.4.39 release
Libva: libva-1.0.15 release
Vaapi-driver-intel: vaapi-driver-intel-1.0.15 release
Cairo: cairo 1.12.3 release

Tried running pcsx2, result is still blank screen...
are you trying gsdx or zzogl?

like gregory stated, gsdx doesn't work on intel yet.
I'd like to add after updating driver, the windows binary I run with wine is become not showing the graphics properly...

I'm using zzogl, I never running with gsdx successfully from the beginning.
You're using bleeding edge stuff that even intel won't support, look for a package that installs the versions intel specified.

or build it yourself

You also need the 32 bits version of the driver. That said, mesa 8.0 must be enough (if my memory is correct). I got a sb system at home. I will do a test. Only mesa is important others part don t impact GL support.

Users browsing this thread: 1 Guest(s)