pcsx2 Running Digital Devil Saga 2 movie subtitles too fast
The verision of pcsx2 I was using for digital devil saga 1 would not allow me to play dds2 in peace, the movies would freeze and not play.

So i got a newer version, .9.7 sumthin. And it plays the videos, but the subtitles under then run really fast and cut the movie off before it's even done playing. THis is just as annoying.

Is there another version, or some settings i can change so I can actually watch the movies and go through the game normally??

Sponsored links

Post your settings, if you're using Vu skip or Speed hack, disable them or simply set the settings to default. I think you should happy that your Pcsx2 running fast Laugh
What setting should I put? THis 0.9.7 Beta is set up weird. And I'm not happy it's cutting off half of videos i actually want to see. There is no VU skip I see, just VU0 is set on microVU recompiler, and VU1 is set on the same. Round mode is chop/zero and clamping is on normal, and the flush to zero and denormals are zero boxes are checked off. I have no speed hacks on.

The video runs at normal speed, and so does the sound. but the Subtitles are moving crazy fast and cut off the video like halfway because the subtitles are already done. UGHGHGHGH!!!!!
Works fine here, show us your settings so we can help better.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Works fine for you???? I definitely need your help then!

I'm using PCSX@ 0.9.7.r3113

Under EE/IOP it's: EmotionEngine set at recomplier, IOP set at recompiler
EE/FPU advanced recomplier options are: Round mode is at chop/zero, Clamping mode is at normal, Flush to zero is checked, denormals are zero is checked.

Under VU it's: VU0 is set at microVU recompiler, VU1 is set at microrecomplier,
VU0/VU1 advanced recompiler options: round mode is chop/zero, clamping mode is normal, flush to zero is checked, denormals are zero is checked

Under GS the disable framelimiting box is not checked, base framerate is at 100, slow motion adjust is at 50, turbo adjust is at 200, NTSC framrate is at 59.94 FPS, PAL framerate is at 50.0 FPS, Frameskipping is disabled, frames to draw is 2, frames to skip is 2, use synchronized MTGS is not checked, disable all GS output is not checked

All speedhacks are off

Game fixes are off
How about plugins and plugin settings? Is your game NTSC or PAL? Is it specific movies or all of them?

Enable the "EE timing hack" for DDS2. I'm basically using the default settings for PCSX2 0.9.7 beta, it could be a sound plugin causing that.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Graphics plugin is GSdx 3068 (MSVC 15.00, SSE2) 0.1.16

Sound Plugin is SPU-x r3117 1.4.0

CD plugin is cddvdGigaherz (r3006) 0.8.0

I tried both PAL and NTSC, which one should I use? Can you give me your settings? and I'll enable the EE timing hack like you said.

Ok, I tried switching the Sound Plugin, and the subtitles are corrected, but now the sound is glitchy and sometimes echoed, and the video looks weird. !? Can i not win!?
Try different settings with SPU2-X, take a screenshot of your current spu2-x settings and post it here but the default ones worked fine for me.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
[Image: 1-3.png]

I switched to another sound plugin and it works, but the sound sometimes repeats briefly.

ALSO big prob, my graphics plugin, I can see through walls, like, I can see the light from the Karma terminal in another hallway.

I need that fixed too.///
Use the latest SPU2-X with those settings and the subtitle problem should be gone.
I bet you either had PEOPS SPU2 selected, or you had SPU2-X set to async mixing.
That's the only reason I can imagine how the problem happened.

The see through shadows are not fixable at this time.
If you can see through the WALLS however, it means GSdx doesn't recognize your game version.
I'll need your game CRC in that case as it is detected by PCSX2 in the console on startup.

Users browsing this thread: 1 Guest(s)