Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2 doesn't want to run on windows 8.1
so i've downloaded and installed pcsx2 on windows 8.1 x64
when i click the icon to get the first time setup, nothing pops up, but it says the program is running on task manager

i've tried this with several different versions of pcsx2, the latest one and some older ones

how would i fix this?

Sponsored links

Are you sure the window isn't minimized or off-screen ?
(01-11-2015, 05:08 AM)uyjulian Wrote: Are you sure the window isn't minimized or off-screen ?

lol yeah, i've checked to make sure i wasn't just being careless or stupid

it doesn't show up on the taskbar either

when i googled it, i saw that someone else had this problem, but it was a region issue, he had his region set to saudi arabia and somehow it made it not work
so he deleted the language setting and somehow it worked?

my region is set to canada, could that be it?
Nope that was only an issue with language AR_SA folder.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
(01-11-2015, 05:46 AM)Blyss Sarania Wrote: Nope that was only an issue with language AR_SA folder.

deleted the ar folder in case it would fix anything, it didn't lol
i've tried different installations, different install locations, adding it as a firewall exception


the first time setup doesn't pop up
Just in case, also try the latest version from here
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Don't bother with the installer. Just get the latest build as stated by Avih and make a PS2 folder. Unpack files into it. Put you bios in the bios folder and boom
MOBO - ASUS Maximus VII Hero
CPU - Intel i7 4790k 4.6GHZ
RAM - 16 Gigs DDR3 2133mhz
HDD - 3 500 Gig SSD 1 3 TB 7200 RPM
GPU - EVGA Nvidia GTX 1070 SC
OS- Windows 10.
just gave it another try, with the above method

clicking it makes new folders pop up in the install directory, and it shows up on task manager, like before

but still no first time setup

it does, however, run on my laptop, which runs windows 7
but my laptop isn't that powerful
Are you running as administrator ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go

Users browsing this thread: 1 Guest(s)