pcsx2 process hangs immediately after launch
I have been using pcsx2 for a while now and it worked fine until today. Now when I launch it, the process appears in the task manager but none of the windows show up. I have already tried reinstalling and repairing the visual c++ 2013 redist x86. Log file is empty.

Any ideas?

Sponsored links

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Are you in an Arabic region by chance? You could try deleting the folders starting "ar" in the Languages folder, in the past this has fixed the issue.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
CPU: Intel® Core™ i5-2500K CPU @ 3.30GHz, 4201 Mhz, 4 Core(s), 4 Logical Processor(s)
Graphics Card: NVIDIA GeForce GTX 1070
Memory: 16.0 GB
OS: Microsoft Windows 10 Home 10.0.14393 Build 14393

PCSX2 1.4.0
Don't think I have any non-default settings.
Can't get to the point where I can choose to play a game. I did find that if I wait long enough the UI starts but it takes minutes, and is slow to shut down too.

I am not in Arabic but deleting the folder didn't help anyway.

Again, this worked 2 days ago and doesn't work today. The only thing that I think is different on my system is that windows installed an update.
Did you also check the 2015 Visual C++ redist? An issue with ghost processes was fixed in recent builds; but I don't think it's related here
Tried visual C++ 2015, same problem.

Users browsing this thread: 1 Guest(s)