Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2 sometimes doesn't really exit
#1
I just noticed that in my task manager I had 4-5 instances of pcsx2 still running, even though I've been exiting the problem as I always do (ESC from game, then close console). It seems random because when I tried to reproduce the problem it didn't occur, whether I ran a game or not. Any ideas?

rev5130 / win7 x64
Reply

Sponsored links

#2
It's a known issue, It tends to happen less, if you don't exit the emu, until after in-game, (during render of 3d). I think somebody has made a .bat to safely shut the emu down, until it's sorted in a furture rev, I haven't bothered with it though, as I haven't found this issue to be a big deal.
Reply
#3
its caused by the mtvu speed hack if you disable that then pcsx2 usually exits normally

you can also do (pcsx2)system -> shutdown
Then pcsx2 will crash if it would of hung up, or it will shut down if it would of exited normally
still beats having to go into task manger every time.
Intel Core I7 [email protected](TB, HT), 6GB [email protected], Geforce 970 G1
Reply
#4
Just make yourself a batch file with the following at the end: taskkill /f /im pcsx2.exe

Reply
#5
its more common in certain games than others.

i've never had it happen with the collection of games i play.
Reply
#6
i've never had this happen at all, (i feel special) using r5117 btw+^_^+
Signature purposefully left blank.
Reply
#7
it's actually pretty easy to reproduce if you use the 'run elf' function (homebrew) and mtvu, I can do it with 100% reproducibility, luckily with games its random.
Intel Core I7 [email protected](TB, HT), 6GB [email protected], Geforce 970 G1
Reply




Users browsing this thread: 2 Guest(s)