pcsx2 the selected plugin failed to load - Redirected to WIN 10
Hi there everyone, I'm new in this forum, pleased to meet you all

I've been using pcs2 for years now and last month I reinstalled my windows 8.1 and I've updated everything through Windows Update

However I think it missed some older updates required by pcsx2 to run, when installing, the message is 
"pcsx2 the selected plugin failed to load" 
I tried to configure my GS in many different ways, it still has the same message.

I think I'm supposed to install something from microsoft, but it redirected me to windows 10 website and I don't want to do that, there is another thread and i think i have the same problem and the solution might be the same but I don't know what it is because now it's only loading win 10 download page not the 'driver' or whatever application I need to install


So do any of you guys know what i'm supposed to install?
Thank you

My spec:
Operating System: Windows 8.1 Single Language 64-bit (6.3, Build 9600) (9600.winblue_ltsb.151121-0600)
           Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK COMPUTER INC.
       System Model: N550JV
               BIOS: N550JV.204
          Processor: Intel® Core™ i7-4700HQ CPU @ 2.40GHz (8 CPUs), ~2.4GHz
             Memory: 8192MB RAM
Available OS Memory: 8076MB RAM
          Page File: 3841MB used, 12425MB available
        Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: 96 DPI (100 percent)
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.03.9600.17415 64bit Unicode

Card name: Intel® HD Graphics 4600
       Manufacturer: Intel Corporation
          Chip type: Intel® HD Graphics Family
           DAC type: Internal
        Device Type: Full Device
         Device Key: Enum\PCI\VEN_8086&DEV_0416&SUBSYS_11CD1043&REV_06
     Display Memory: 1792 MB
   Dedicated Memory: 32 MB
      Shared Memory: 1760 MB
       Current Mode: 1920 x 1080 (32 bit) (60Hz)
       Monitor Name: Generic PnP Monitor
      Monitor Model: unknown
         Monitor Id: LGD0323
        Native Mode: 1920 x 1080(p) (59.975Hz)
        Output Type: Internal
        Driver Name: igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
Driver File Version: 10.18.0010.3308 (English)
     Driver Version:
        DDI Version: 11
     Feature Levels: 11.0,10.1,10.0,9.3,9.2,9.1
       Driver Model: WDDM 1.3
Graphics Preemption: DMA

Sponsored links

try this
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
worked like a charm, turns out this is what I was missing. Thank you!

You just have to extract the download somewhere and run the exe in it and kaboom, it works.

Thanks again

Users browsing this thread: 1 Guest(s)