problem with states
HI! firstly thankyou for Your work!!! that's an amazing program!

I am writing this post because I have a problem: when I play finalfantasy XII the program works fine, but if I want save a state (file->states->save->slot 0) and then load slot 0, it crashes saying "Error: Savestate data is corrupted or incomplete
Filename: Tag: mtgs".
There is the write of gamerunning:
Saving state to:  Memory
        Saving GS
Closing plugins...
MTGS > Closing GS thread...
* CDVD: IO thread finished.
Plugins closed successfully.
Saving state to:  sstates\C1274668.000
        Saving SPU2
        Saving DEV9
        Saving USB
        Saving PAD1
        Saving PAD2
State saved to slot 0
Loading state from:  sstates\C1274668.000
Bios Version 1.60
Opening Plugins...
MTGS > Thread Started, Opening GS Plugin...
MTGS > GSopen Finished, return code: 0x0
* CDVD: Opening drive '\\.\F:'...
* CDVD: Disk Type: Double-Layer DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * * Track 1: Data (Mode 2) (1966528 sectors)
CDVD: IO thread started...
Plugins opened successfully.
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
Encountered an error while loading savestate from slot 0.
Since the savestate load was incomplete, the emulator has been reset.

Error: Savestate data is corrupted or incomplete
        Filename: Tag: mtgs

I am using the last beta program and plugin. I have updated both Directx and Visual C++ Redist package. I am using windows 7 32bit on a dualcore 2.0 gigah, with geforce 8600m gt. I don't know if with other games the program crashes because I have only finalfantasy XII.
Anyone can help me?? or has the same error??

note: I tried to use 0.9.6 with same plugins of beta and if I use "cdvdGigaherz (r2361) 0.8.0", the game doesn't start, but if I use "P.E.Op.S (CDDA mod) 1.3.0" the game starts and savestate works.

Sponsored links

Use the hotkeys. F1 to save, F2 to change slot, F3 to load
[Image: newsig.jpg]
thankyou very much!! now it works!
Just another question: how can I see log messages while I'm playing?? For example, If I press f2, I would see on screen "selected savestate slot 1".
In the lilypad plugin there is an option to show the current slot number in the titlebar.

Edit Spelling
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
You can't. But if you play on windowed, you can enable a hack in the Lilypad plugin to display the slot number you currently have selected in the GS window title bar
Edit: ninja'd Sad
[Image: newsig.jpg]
ok, thankyou very much agan!! Laugh

ps: why "edit spelling"?? I am italian and If I did language mistakes please, excuseme..
GamerGeek was probably referring to himself and not you; could be because he edited his own post to correct a spelling or two. Wink
Intel C2D E6550 2.33GHz ([email protected])
Corsair CM2X1024 4GB (4x1GB) DDR2 DRAM
XFX Radeon HD 5770 1GB

Running on Windows 7 Home Premium 64-bit.
That is why Smile
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
ok Smile

Users browsing this thread: 1 Guest(s)