Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
reservoir dogs screen bug
#1
hi guys

I thought i'd ask because this has been bugging me for a while i am playing reservoir dogs and it normally runs fine but whenever i enter bullet festival i get a weird screen glitch with horizontal lines. i have tried running this in native and a few custom resolutions but i have had no luck so far.

my pc specs are

windows 8
acer
aspire v3
intel® core™ i5-3230m cpu 2.60ghz turbo boost up to 3.2ghz processor
installed memory 8.00 (7.82 usable)
system type 64-bit
nvidia 710m geoforce

i am running the emulator with these settings

EE/IOP
recompiler, recompiler, negative, extra+preserve sign

VUs Microvurecompiler, microvurecompiler, negative, extra+preserve sign

gs
default

speedhacks
EE cyclerate=1 Vu cycle stealing=3, enable INTC spin detection, Enable wait loop detection, mvu flag hack and mtvu
no game fixes.

video plugin settings
adapter= NVIDIA geforce 710m
renderer direct 3d11 hardware
interlacing= none
custom resolution= 1020x1020
texture filtering= not checked i squared it i don't know the official term lol.
allow 8-bit textures= checked

and that's it if u need anything else please feel free to ask but if anyone can help me fix the horizontal lines i would be very grateful as my copies of the game don't seem to work on my ps2 and i would really like to play it.

thanks you Smile

Sponsored links

#2
It's most likely because of the VU cycle stealing. Try with out. Also moving this to where it should be. Also why are you using non default rounding/clamping?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#3
ok thanks for the reply ill try without VU, i use non default because for some reason the settings i use work perfect with dragon ball z and a bunch of other games i dont know why tho. by the way sorry if i posted this in the wrong place im new to the forum Smile
#4
You should generally use the default rounding and clamping modes unless the compatibility list tells you otherwise.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#5
ok it seems to be working fine for the games i use anyway but same games i have to change it back, by the way i tried the vu cycle and it didn't fix the problem but it did increase my fps which i had slight trouble with so either way im happy Smile im starting to think it could just be the iso because this is the only game it seems to happen to and i have spent 2 hours doing different settings and no luck i can play the game fine otherwise so ill just put up with it when using bullet mode wich is rare anyway Smile thanks for your help
#6
Sorry for bringing this back from the dead, but I just encountered this problem checking out my old Reservoir Dogs PS2 and registered here for this because I'd be happy to hear if there is any workaround for the glitch by now. It's annoying , although it's not a game breaking bug. I didn't find any other information besides this thread anywhere in the net.

My Specs:
Operating System = Microsoft Windows 10 Pro (build 16299), 64-bit
Physical RAM = 16317 MB
CPU name = Intel® Core™ i7-8700K CPU @ 3.70GHz
Vendor/Model = GenuineIntel (stepping 0A)
CPU speed = 3.638 ghz (12 logical threads)
GTX1080 Phoenix GLH

I tried to run this all other settings on default in Hardware OpenGL, D3d9 and D3d11 rendering modes on 1.4.0 stable. All showed the glitch when using bullet festival. What vader20555 hasn't written: You can get rid of the glitch in software mode. This is or course not desirable because of reduced performance & lack of scaling options.

(The latest nightly pcsx2-v1.5.0-dev-2319-gf6e4a3081 has this game broken in toto, it seems. Colors are messed up all the time, and software mode didn't help in that case).

So is there any way to tweak this game into getting rid of the "bullet festival" glitch in 3d hardware modes? As I have just been using Psx2 for some days now, I'm not too knowledgable about all the other settings.
#7
Can you make a multiframe GS dump of the issue (hold CTRL + SHIFT + F8 for about a second while the issue is visible)? https://forums.pcsx2.net/Thread-How-to-c...er-GS-dump
#8
Of course. Should I do a seperate dump for each of the hardware modes D3d9, D3D11 and OpenGL? Or just one of them?
#9
(03-07-2018, 05:14 PM)blam666 Wrote: Of course. Should I do a seperate dump for each of the hardware modes D3d9, D3D11 and OpenGL? Or just one of them?
One dump is fine. The renderer doesn't matter.
#10
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)