[solved] video plugin problem?
Hi there and greetings from Italy.
I (hope) correctly downloaded and installed pcsx2 from the AUR 2 days ago, but when I try booting a game using any video plugin but GSnull, it crashes (blank unresponsive window) and I have to pkill it from terminal. Any idea of what am I doing wrong?

os: Arch Linux x86_64
ram: 6gb
cpu: Intel i5 430M
gpu: nvidia GeForce GT 320M

Sponsored links

optimus ?
nope :/
if I launch it from command line I get this output with ZZ Ogl PG 0.4.0 [libzzogl-0.4.0] plugin (nothing at all after the startup with GSdx (GCC 4.7.1, SSE2) 0.1.16 [libGSdx-0.1.16] )

[mirko@jules ~]$ pcsx2
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
Loading language translation databases for 'Italian' [it_IT]
Command line parsing...
Command line parsed!
ZZOgl-PG:  Calling GSinit.
ZZOgl-PG:  GSinit finished.
ZZOgl-PG:  Calling GSopen2.
ZZOgl-PG:  Capturing ZZOgl window.
ZZOgl-PG:  Got Doublebuffered Visual!
ZZOgl-PG:  glX-Version 1.4 with Indirect Rendering !!! It will be slow
ZZOgl-PG:  glGetStringi opengl 3 interface not supported, fallback to
opengl 2
ZZOgl-PG:  Supported Opengl version : 1.4 (2.1.2 NVIDIA 304.37)

ZZOgl-PG:  Using multitexturing.
ZZOgl-PG:  Maximum texture size is 8192 for Tex_2d and 8192 for Tex_NV.
gl error GL_INVALID_ENUM(0x500)
gl error GL_INVALID_ENUM(0x500)
ZZOgl-PG:  Failed to create the renderbuffer.
gl error GL_INVALID_OPERATION(0x502)
ZZOgl-PG:  Disabling MRT depth writing.

so I guess it should be something to do with te gpu, but I don't know what I have to do to fix it Smile
Quote:ZZOgl-PG: glGetStringi opengl 3 interface not supported, fallback to
opengl 2
ZZOgl-PG: Supported Opengl version : 1.4 (2.1.2 NVIDIA 304.37)

Your driver is badly installed or you're driver is craps or you miss to install the 32 bits part of the driver. You need to have opengl 3 support.
Big Grin 
Thank you so much! If anyone run into the same issue: I solved it by following this guide on Arch Linux wiki. All I was missing was lib32-nvidia-utils.Glare
Have I thanked you yet? Yes? Well, thank you again! And, of course, +1 for you. Smile

Users browsing this thread: 1 Guest(s)