the famous FFX freeze bugs
Hello all,

I am trying out PCSX2 for the first time and I have to say 'WOW - great work!'
I have a problem though when playing FFX and it seems to be a well known one. First I suffered from the 'Auron look' bug but I got past that by dowloading a saved game after that scene. Then the same problem happened again on the boat to Kilika when Sin attacks.
I tried soo many configurations to get past that point that you probably wouldn't believe it, I also tried 3 different PCSX2-versions (0.9.4, 0.9.5 beta and 0.96 (the one I started with)). I tried configurations posted elsewehere but nothing helped.
I tried all Graphics plugins, all sound plugins and all CDDVD plugins, I also tried playing from DVD (original) directly and from an .iso-file.
Finally when trying on 0.9.5 I stumbled upon some interesting console output and I was wondering if that output might give someone here some clue as to what the problem behind that bug might be.

During gameplay I constantly see messages in the console of the following format:

DvdRead: Reading Sector xxxxx(x Blocks of Size 2064) at Speed=4x

But right before that freeze bug on the boat to Kilika happens (I haven't checked if this is also the case with the Auron look bug) I get a different console output

CdRead: Reading Sector 2198921(1 Blocks of Size 2048) at Speed=2x

Is it normal that the program does a CdRead instead of a DvdRead at that point?

btw. my version of the game is SCES 50492

Any help or answers would be appreciated.

Sponsored links

ok, I just checked and I guess I posted too early. There is always CdRead when a video is being played. And other video sequences play just fine even though they read from cd.
So my only hope left is that the problem is with my FFX DVD. I had no problems playing through that part on the PS2 with it though. I will check this with the DVD of a friend.
(my own PS2 broke in case you were wondering why I am bothering at all)
ok, this is solved.
I got the DVD of a friend and it does not freeze anymore. Neither on the boat on the way to Kilika nor does the Auron look bug happen anymore. This was definitely a bad DVD/ISO problem.
now off to play Smile
Well the only known freeze bug of FFX I'm aware of is in Thunder Plain, which you may encounter later.

Users browsing this thread: 1 Guest(s)