Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
underwhelming performance on midnight club 3
#1
yo

so i originally had played SSX 3 and it ran great. stayed at a constant 60 fps without any frame rate dips, it was sweet.
i recently tried playing midnight club 3, and my fps drops to as low as ~35fps.

Ryzen 1600 3.8GHz
GTX 1060 6GB
8GB 2933MHz RAM
Windows 10

sooo whats the deal? ive searched for solutions, and ive had mixed results. ive tried DX11 and OpenGL, neither seem to be superior to the other. im using 2 EE cyclerate, 0 VU cycle stealing, and MTVU. its frustrating that this game runs so poorly for me, considering ive seen videos from people with much worse specs running this game at a constant 60fps.

id appreciate any help Laugh
Ryzen 1600 3.8GHz
MSI GAMING X GTX 1060 6GB
8GB 2933MHz
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#3
Level 2 EE cyclerate might be slowing it down since it increases CPU requirements. Try dropping it to 0 and see how that does.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#4
(06-23-2018, 08:23 PM)CK1 Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

1.4.0


Attached Files Thumbnail(s)
       
Ryzen 1600 3.8GHz
MSI GAMING X GTX 1060 6GB
8GB 2933MHz
Reply
#5
have you tried lowering the Internal Resolution? I think MC3 is quite GSDX heavy

But yes, lower that EE slider too, you're only making the game run slower for yourself, that's not going to make anything faster. (Tip: read the RED text under it, it states the hardware requirements are increased)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
What EE is useful for is for games that on the PS2 hardware run slow. Think of it is overclocking the virtual PS2 system.
Shadow of the Colossus has a variable framerate on the PS2 and if you have a spare super computer lying around you can get it running really fast with a higher EE setting.
Reply
#7
You might want to try the latest latest pcsx2 1.5.
CPU : I7 6700 3.4 Ghz
GPU : Nvidia Geforce GTX 750 TI
SPU : Realtek High Definition Audio
RAM : 8 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#8
i am now using 1.5.0
tried changing the EE cyclerate around, but its running just really poorly in general. since i updated to 1.5.0, i rarely get more than 40 fps and generally have ~25 fps. i also lowered the resolution to native...

i really dont understand why its running so poorly. my hardware is relatively high end... any other suggestions?

btw, thanks for the help so far guys Smile
Ryzen 1600 3.8GHz
MSI GAMING X GTX 1060 6GB
8GB 2933MHz
Reply
#9
can you show us your GSDX settings again on the new version?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(06-24-2018, 10:53 PM)refraction Wrote: can you show us your GSDX settings again on the new version?

yessir


Attached Files Thumbnail(s)
   
Ryzen 1600 3.8GHz
MSI GAMING X GTX 1060 6GB
8GB 2933MHz
Reply




Users browsing this thread: 1 Guest(s)