xbox 360 controller issue
Hey all, first post and I will try to make it brief.

I have a small problem with Kingdom hearts 2. I dont know if this is specific for just that game or if its a general problem.

The problem is the analog stick and controller. When I try to run up/right and up/left (for diagonal running) it just dosent. Roxas/Sora just starts walking instead. When I press down/right and down/left it usually works but sometimes the same problem occurs. Just running left,up,down or right works perfectly though.

I figured it has something to do with how the pad plugin reacts to how hard I press the analog stick. In KH2 when you press the analog just slightly the character you control is suppose to walk and if you press it hard (all the way) the character should run.

First I tried lilys plugin (0.9.9) with XInput only (as stated in their thread) with the same problem. Then I switched to Xpad (the one that's made for xbox controllers) and still the same problem.

I've looked at the calibration configuration in windows and it seems to work there. It reacts as it should do. I've also tried a different controller but again the same problem.

So what could be the problem? Unfortunately I dont have the opportunity to try a different game but somehow I doubt it's the game or the programing towards it.

Xbox 360 controller
Windows vista business 64 bit
Running latest pcsx2 (r478)
Tried both Lilypad and Xpad plugin

ps: It actually works if I press the analog not too hard and not too soft (like halfway towards the edge) But if I press it all the way it dosent. Am I crossing a reaction threshold of some sort?

Sponsored links

same with me, but it doesn't depends on the plugin because it happen's with EVERY pc game.
You can fix it by setting a larger sensitivity to the analog sticks with Lilypad. I've currently set it at 1.381 and it works fine
[Image: newsig.jpg]
(02-15-2009, 03:53 PM)Bositman Wrote: You can fix it by setting a larger sensitivity to the analog sticks with Lilypad. I've currently set it at 1.381 and it works fine

Thank you Boistman, works like a charm!

I thought I should've try changing the setting there but better to know for a fact what value would work without messing something up.

Its too bad Xpad dosent have something similiar (like sensitivity option) because its nice to be able to just play without setting any buttons. Then again maybe that possibility is nice too.

Well thanks again!

EDIT: Well after considering, it should be MS that provides that option in its gamepad settings if the problem consists in pc games too..
there are modded drivers for the xbox 360 gamepad that maybe do a better job than the ones from microsoft. google after "xbcd".
You can find the drivers here.
They are way better than the Microsoft drivers, im using them and donĀ“t have any problems.

OS: Vista x64 Ultimate (SP1)
CPU: Intel C2D E6600 @3 Ghz
GPU: XFX GeForce 8800 GTX (768Mb)
Motherboard: Gigabyte EP35-DS3
Those drivers work wonderfully when the game, program etc. uses directx eg. pcsx2, epsxe, project64, snes emus etc.

But I find if it is a new PC game, with Xinput support, that the xbcd drivers sometimes make the xbox360 controller behave erratically. In the new tomb raider games, everytime I boot them up, I have to reassign the buttons to the controller. In GriD, with xbcd, the analog sticks don't work properly but with the xbox360 offically drivers it works beautifully.

On the other hand, the xbcd drivers have better rumble support. Wink
Intel Core i7 @ 2.66 Ghz ~ 6 GB DDR3 Tri-Channel ~ 512 MB Radeon 4850 ~ 500 Gb HDD/160 GB HDD/80 GB HDD ~ 24" LCD
since this thread appears in xbcd related searches...

that old xbcd360 site is long gone, you can get all xbcd related updates @ from now on

Users browsing this thread: 1 Guest(s)