..:: PCSX2 Forums ::..

Full Version: Bug report on PCSX 0.9.7 settings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8
i have installed the new version but when i tried to sun it it went into the first start config stuff which is fine

but when it gets to bios selection it cannot see my bios

i have pointed it at the correct folder and there are 5 files in there, but it has nothing to select in the "select your bios" bit

any help?
make sure the main file is called .bin, not .rom0
doesnt have rom0


which one is main?
none of them... you need to redump your bios.

Althought looking at your previous warning, i doubt that is even yours.. Plus the fact its difficult to miss 1 file when youre dumping it all yourself.
its been working fine up until now, i dont know whats going on...
Hello, this is my first post. So I installed the latest beta version of pcsx2 yesterday. Everything seems to be working fine, I've got a game working, but there is one problem and it's annoying. Pretty sure this thread had the same problem as well, but I read through it and didn't see a solution. Anyways, whenever I go to "Configure," "Emulations," and then "Window" to change my resolution, it works. [Edit: I get an error similar to this whenever I pretty much try to change anything] But it has this error:

[wx] Failed to copy the file 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsDDE3.tmp' to 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsx2.ini' (error 5: access is denied.)
[wx] can't commit changes to file 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsx2.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file.

And then if I close out, I have to reset my resolution when I log in next time. I installed everything where it's default was. Pcsx2 is installed here: "C:\Program Files (x86)\PCSX2 0.9.7\pcsx2-r3113.exe"

And I have the pcsx2 folder in my documents. Here's the location for it as well: "C:\Users\Nathaniel\Documents\pcsx2"

The inis folder is there as well, along with those files. It's more a matter of access I'm guessing. (error 5: access is denied.) I have it set to run as an administrator and I'm logged in as an administrator. My operating system is Windows 7 64 bit. And that's my problem. I don't know what to do. Any help would be very much appreciated.
Access denial is OS responsibility, an application can't and shall not have rights to change it, it's a fundamental security feature.

So, if it is happening to you is in your own privileges related to the files you must look upon. Being in the administrator group is not enough if the ownership is wrong and no write, read and/or execute access is given (although an administrator can change that setup).

PS: The UAC is a common source of "strange" behavior since it can silently negate the needed access to resources for applications, move files to hidden folders and some others uncommon things.
That did it. Thank you very much! I'll say what I did to fix this problem. For observers who might not understand what to do.

I right clicked the "inis" folder and went to properties. Then I went to the "Security" tab. I clicked the "Advanced" button at the bottom. I then went to the "Effective Permissions" tab and pressed the "Select..." button. I then clicked the "Advanced" button and then the "Find Now" button. After that I selected "Administrator." I suppose you could also select "Administrators." I then just said okay to everything. This solved my problem. Once again, thank you nosisab Ken Keleh.
I thought that we had fixed the problem. It worked at least once, but the problem is back. I left my game to mess with speed hacks and I got this error message:

[wx] Failed to copy the file 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsDA49.tmp' to 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsx2.ini' (error 5: access is denied.)
[wx] can't commit changes to file 'C:\Users\Nathaniel\Documents\pcsx2\inis\pcsx2.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file.

I then went back to the windows tab and messed with it. I got the same error as last time. I went back and repeated the steps I had taken in my last post, but that didn't change anything. I looked in the "inis" folder and this time I noticed that the "pcsx2.ini" file was missing. I'm not sure if this file suddenly disappeared, or if it was never even there. I thought it was present before though, as my first post says. Any thoughts?
The message may be misleading and the denial is not to copy to the ini but to create the tmp itself. That normally happens when the application itself is in the Documents folder (as in any folder under the /users). That is because that folder is one the most "secured" by Windows, less than the System(32) but more than the C:\Program files itself.

For the UAC is not the user trying to access the resources but the actual application and may be there the problem. Although I'm not sure enough to state it positively, my experience show me running applications under the Documents folder is bad idea from the UAC view point.

What I recommend you to try is leaving the emu root folder away from C:\Program files or the Documents folder (although the inis and others can be there) and turning UAC completely off, at least while playing the emulator (as any game that allows mods, like Oblivion, Fallout 3 and the likes).

This way you can play it without setting the administrator flag and it should work.

PS: UAC is somewhat a dumb feature because the security enhancements it brings are killed by forcing to run several applications, mainly games, with administrative privileges and to worsen things, most those applications are the ones that need Internet access. I don't try to understand those guys from MS anymore... Still I'll not advise turning UAC down all the time, it's something everyone should search and weight for themselves. For myself I want nothing with this "thing".
Pages: 1 2 3 4 5 6 7 8