..:: PCSX2 Forums ::..

Full Version: Persona 3 + 0.9.7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey ,
I recently found this emulator decided to play some persona 3. Im using an iso and the 0.9.7 version on win 7 64 bit on a 2010 13' mbp with the 2.4ghz processor, i also know that they r not the best performer in terms of well anything but thats not the point of this topic. Basically persona 3 plays fine and looks beautiful however sometimes something rly weird happens. The sound stutters or lags im not rly sure and at times slows down or even speeds up! I looked up a few videos on utube bout a guy playing persona 4 on the same machine and it looks fine and he aint experiencing the stutter/lag whatever. I tweaked the settings a bit and noticed that by putting the graphics to dx9 hardware this decreased but was not eliminated. I attempted tweaking the sound settings aswell as in changing the quality n stuff...no luck. Soo i was wondering what the problem might be and if there is a solution to it. I was thinking, yes my machine is slow but another 1 is not experiencing the same problem?? Or could it be an issue with the iso??
Thanks for your help in advance
So, is your MBP the one with the 2.4Ghz Core 2 Duo and GeForce 320M?
Yep thats the one.
That GPU is not that great, so I'd say stick with native resolution. I think your processor should be enough, might need some Speedhacks for decent speed.

I'm not sure what other advice to give you, as I haven't tried emulating this game myself. I can tell you not to put too much faith in YouTube videos. The built-in video recorder can record gameplay at any speed, yet playback will be at full speed. Just sayin'...