..:: PCSX2 Forums ::..

Full Version: PS3 Controller broken after using it with PCSX2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I connected my ps3 (dual shock) controller to my mac to use with pcsx2. Everything went smoothly, but now the controller isn't working properly. It won't turn on without being plugged into either my mac or the PS3, and it turns off immediately when I unplug it.

I've tried resetting the controller many times with the reset button on the back of the controller. I even went as far as replacing the battery, thinking that the battery had gone bad, but after taking out a battery from a fully charged PS3 controller and putting it into the broken controller, it still won't turn on.

Can anybody give me some help? Like I said, i've tried resetting the controller just about every way I can think of, but to no avail. Do I just have a broken controller that will only work wired now? I hope not. Any help will be appriciated.
turn off the bluetooth on the mac..

re-run the bluetooth synchronisation on the ps3.
Yes, seems like the sync is acting weird, for me normally plugging it into ps3 and pressing ps button resyncs it ok
yeah. as long as the ps3 is on. sometimes you need to hold it for 10 seconds or until the lights start blinking differently. I switch between my mac and my ps3 being synched to my controller almost daily.
For Some Strange Reason PCSX2 is Breaking Devices like DVD Drives, PS3/PS2 Controllers, I think Sony Elite are Trying to Kill Us
Thanks for the suggestions (well, except for the completely sarcastic non-helpful comment).

The bluetooth is indeed off on the mac that I had it plugged in to. Actually I don't think I ever got it working wirelessly with the mac, I just used it plugged into a USB port.

I might not have been clear enough in what is going on. This is what I try to do to fix the controller.

With everything off, pushing the PS button on the controller does nothing. The red LED's on the controller don't light up at all, nor does the PS3 turn on.
Plug the controller into the PS3's USB ports and hit the PS button - again nothing. No lights, no power.
Turn the PS3 on manually, then hit the PS button on the controller - controller lights up and connects as controller #1.
Let the controller charge for a half an hour (just in case) and unplug the USB cable - controller turns off immediately and won't turn back on.

Now at every stage of this I have tried resetting the controller with the little reset button on the back. Reset it with everything off. Reset it before plugging it in and after plugging it in. Reset it after plugging it in and the PS3 identifying it. All of which has done nothing.

Maybe something got borked on the circuit board other than the battery (like I said before, i've tried two different batteries out of working controllers with the same outcome). Who knows. If anybody else has a suggestion for something I haven't tried, let me know.
have you tried holding the ps3 button while plugged into a ps3 that is turned on until the lights blink differently??
(09-08-2011, 09:27 AM)mubbsy Wrote: [ -> ]have you tried holding the ps3 button while plugged into a ps3 that is turned on until the lights blink differently??

Doesn't seem to do anything for me. Holding down the PS button with the controller plugged into the running ps3 does one of two things for me. If the controller is off, it connects and identifies as controller #1, and no matter how long I hold the PS button, nothing happens. If the controller is on, holding the PS button just brings up the 'Turn controller off/Turn system off' screen, nothing else.

I'm really beginning to think that something weird happened to my controller that has no explanation or fix...

edit: fixed typo
Sorry about the necropost, I ended up here via a search, but I am having the exact same issue. The controller works when it's plugged in, but immediately flatlines as soon as there's no USB-cable connecting it to the console. It might be that the wireless driver gets overwritten when configuring the controller via the PC software, so I'm wondering if there is a way to restore those settings to default. The "reset" button on the controller also does nothing. The controller is effectively a brick without the cable.

My controller is a Sixaxis, but the problem is identical.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.