..:: PCSX2 Forums ::..

Full Version: language glitch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I have been playing PCSX2 for all of a few weeks, and for some reason, it's acting up. I noticed that in some games (sonic riders, shadow the hedgehog) the language is in what appears to be Japanese, and in shadow the hedgehog in particular, it sometimes didn't show the text at all (grey area where text and other animations were supposed to be). I have tried multiple game fixes, with speedhacks and frameskip both enabled and disabled, but I couldn't get it to work.
Also, the one game that I could play at full speed (Sonic mega collection plus) wasn't able to play the first time this glitch came up. (it said something about unable to load cdvd, I had to go into task manager, find the process, and kill process tree to fix.) Afterward, sonic mega collection worked, but shadow the hedgehog and sonic riders still had the language glitch. Shadow the hedgehog has yet to give me the grey-text glitch again, however.

I have ensured that the PS2 (emulator) itself is set to english (system config>language>english.
I have also all but confirmed that my computer is a piece of crap, for a dual core.
PCSX2 program log: (since I'm new and don't know what info will help or not)

Thanks in advance!

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 32-bit
Physical RAM = 1918 MB
CPU name = AMD Turion™ 64 X2 Mobile Technology TL-50
Vendor/Model = AuthenticAMD (stepping 02)
CPU speed = 1.595 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00002001
x86EFlags = ebd3fbff

x86 Features Detected:
MMX2 .. 3DNOW .. 3DNOW2

Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
ATI Radeon Xpress Series (
Binding PAD : C:\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : C:\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 639ms)
you need to configure the biose's language.
like you would do on your PS2
I'm pretty sure I already did that. I also tried with different BIOS
just use the one from your PS2.
when you used those games on your PS2, what was the language ?

Tried using full boot instead of fast boot, too ?
Ok, using a COMPLEATLY different bios file, I managed to get it to display English for sonic riders. The issue still stands for shadow the hedgehog.
I also noticed that shadow the hedgehog is only playable "in-game." I'm not sure, but might that be why?
Also, as soon as I stuck shadow the hedgehog into there, that set of BIOS started emulating sonic riders in that Japanese language too. Maybe I should not try to play it?
Quote:when you used those games on your PS2, what was the language ?

Tried using full boot instead of fast boot, too ?
I'm not sure what the language was... I booted BIOS with no disk, and it read english, so that's not the issue :/