..:: PCSX2 Forums ::..

Full Version: Battlefield 2 Modern Combat Graphical Glitches
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having an issue in BF2 where, during gameplay, a small portion of the top of the screen will render when using DX9 or 10 hardware (works fine in software (F9) but is too slow) but the rest will be all black. What's strange is that the portion that is displayed is actually fairly responsive. On my system, speedhacks would make it fairly playable if the rest of the screen wasn't all black. A new system could probably handle it no issue, but I believe the graphics issue to be a glitch and not just lack of speed. I've tried the Alpha Hack in Gs, some different skipdraw values, various speedhacks, native resolution and 8 bit textures. Does anyone have any other suggestions that might fix this?
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Sorry, that should have been obvious to me. Posted late last night :/

CPU: Core 2 Duo E7300 @2.66GHz
Memory: 4Gb DDR2
GPU: Nvidia GeForce GTX 260 Core 216
OS: Windows 7 64bit

Versions of PCSX2 Tested (all 64 bit): 0.9.7, 0.9.8, 1.0.0

I did set GS to SSE3, which should be supported by my processor. I also tried the default SSE2. I've ran both under DirectX9 and 10, both with the same result. Other than that and the hacks mentioned in my post above I'm using all defaults.

I'm playing Battlefield 2 modern combat from iso ripped with Alcohol 120% under ps2 setting. I used WinDIP to add the DiscID. The PCSX2 doesn't have any confirmations on this game so I guess it's gone under the radar so far. I'm also going to try this on my laptop, which is a bit faster, IF I can ever get the drivers and DirectX to install. Optimus is such a mess. But I have a feeling this is a glitch more so than lack of performance. I'm hoping maybe there will be some other hacks I can try...

I am almost able to play the game on my laptop in software mode by adding a couple of extra rendering threads for GS. It runs at 40-50 fps, which is just slow enough to make it difficult to play. Frameskipping is not really an option with this game, so I'm still hoping for a hardware hack to make this playable. Note that I did have to use the tool below to prevent GS from throwing an "out-of-memory" error.

Quote:so I'm still hoping for a hardware hack to make this playable

The only "hardware hack" that will be done is from your side.
Something like a "buy a recent CPU, yours is quite old".
Should have been more specific. I'm hoping for a hack that will allow GS's hardware mode to work. Something like the alpha hack or a certain combination of hacks and skipdraws. Some odd resolution maybe. Just something that I haven't thought to try yet or may be unaware of. My laptop has a Core i5 M450 and the game is almost playable in software mode as I described above. And yes, the cpu in my desktop is pretty old...