..:: PCSX2 Forums ::..

Full Version: Final Fantasy X FMV issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have to say first; the last time I did anything with this project, it was almost unplayable. My system was not up to spec and few games were playable. Now, things have definaitely changed! I am pleased! Thasnk you to everyone.

Now on to the dirt.

I've been playing around with both the 'official' release and playground release. I downloaded the latest SVN and comiled it. I have found several combinations of plugins, configurations and speed hacks which allow me to play most of the PS2 games I still have at average 100% speeds. Lowest I think was 80% in FFX, but speed problems are not the issue here.

When Tidus meets Wakka and on the ship after meeting the summoner (I stopped playing after this), the screen starts strobing badly. Basically the last non-FMV cutscene is static while the FMV flashes in and out. You see the last frame of the cutscene a a messe dup FMV at the same time. When the FMV ends, everything is alright. I have spent 4 hours after work for 3 days trying to figure it out. Changing settings, loading the game, starting from save states and not, killing the entire directory and creating a fresh install of the different version, reading posts after posts on this forum and ngEmu (doesn't help when people have titles of 'help!!' and 'FFX help please!!!')...

Basically i've done all I can think of to find the answer on my own. I know the desription isn't helpful, and I can't get a screen-capture of the game. Does anyone have a clue what might be happening?

AMD 6400+ Athlon X2 at 3.2GHz
XFX (nVidia) GeForce 9600GT
4 GB RAM DDR2 PC2-6400 800MHz Patriot memory (4-4-4-12 2.2V) (62% free)
Windows Vista Ultimate x64

Config (current. Remember I tried many settings)
Graphics: GSdx 883 (MSVC 15.00, SSE2) 0.1.13
+Direct3D 10 Hardware
+no interlacing
+NLOOP Hack on
+Texture filtering
Controller: SSSPSX PAD Plugin Pressure Mod 1.7.0
CDVDROM: Linuzappz ISO CDVD 0.7.0
Sound: P.E.Op.S SPU2 1.9.0
+medium volume
+No reverb
+simple inerpolation
BIOS: USA v02.00(14/06/2004) Console
+EERec on
+VU0rec and VU1rec on
+MTGS mode on
Speed Hacks
+Use 3x cycle rate on
EE Recs Options
+Round Mode Nearest
+Clamp mode None
+Flush to zero and Denormals zero are on
VU recs options
+Round Mode Nearest
+Clamp mode None
+Flush to zero and Denormals zero are on

I think that's it other than the SVN version of playground (best choice so far) SVN: 690

I also tried the version of the SVN that is compiled and ready for download here on the forum...

help please if you can? or just post one of the threads you guys think i missed. I do know how to read Wink

Also let me know if I missed giving any info.
Did you try using ZeroGS instead of GSdx? I had a similiar problem with Kingdom Hearts 2, and switching to zerogs fixed my problem. Maybe you should try, I don't know =)
You must be joking, you use 3x cycle rate on and expect FMV to work perfectly?! Even with 2x cycle FMV of some games don't work well for exemple Tekken 4.
I have the same problem, but without speed hacks only cycle rate at 1.5.
Im gonna try it with normal Cycle rate, but i think i had the same problem even with 1x cycle.
I tried many different configs but couldn´t find a fix yet Sad
try different versions of GSdx there already a 0.1.14, if it doesn't work post a savestate here a will try seing must be pal for me to test it.
Im using the 0.1.14 version of GSDX. But im currently playing FFX (PAL), i will try to make a savestate just before a FMV starts.
Here is the savestate for PAL version. The FMV should start about 5 seconds after you load it:
Download Savestate

The file was too large for an attachement, so i had to upload it on rapidshare.
Im sorry if this is against the rules, in that case just delete my post.
@seinfeldx: even with the 3x off (no spee dincrease int hat area) I still have a problem. Remember, I've been trying many changes. When I first ran the game, I was getting a good ~50 fps, with no speed hacks. I tired zeroGS and if I remember, was still experiencing the issue.

As soon as I get home in...9 hours I can upload a savestate also. My version of FFX should be NTSC. I'll post the disc ID (SLUS-XXXX) when I get home.

The thing with the 3x...I've been maximized my emulation speed. I can run ~58-60 fps with very few drops, with a few programs running in the background. That was my reasoning. I will be turning it off just to check if it helps, incase I missed it. But I have stayed away from zeroGS because of framrate issues.

Excuse the typos....too lazy toe dit properly. Just woke up and alreadyat my desk at work...
I have the same problem with all options set to default.

Pete's SPU
GSdx 0.1.14 (SSE$4)
Direct X 10

This problem does not occur when I use ZeroGS though. So that's what I use to play FFX.
Yea you´re right, ZeroGS doesn´t have this Problem, but GSDX has much better graphics and is faster Sad hope someone finds a fix for this.
Pages: 1 2