..:: PCSX2 Forums ::..

Full Version: Tales of the Abyss unstable framerate
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

First, I've already checked previous threads in order to find an answer (just a topic that mention the same problem without answer)...

In Tales of the Abyss I've got huge FPS drop on some cut scenes/villages : 60 to 10 FPS.
The issue appears only in some villages (ex : in Keterburg or in engeve)

Otherwise, the game runs great at 60 FPS the whole time (Fights,Map and the main part of the villages of the games).
I've turned all speedhacks on exept the 1.5x, 2x or 3x options (these options solw the game in general)

I use PCSX2 PG r528, and GDSX9 (Winxp) (SSE4.1) 0.1.14 on a [email protected], 2Go pc8500 and a ATI HD4850.


I've tried, ZeroGS plugin :Fps are stable around 60fps whole time but I have artefacts (I've tried a lot configuration without success).
I also tried to configure pcsx2 and gdsx in differents ways but it keeps ending on the same issue whatever the configurations I use.

Thanks by advance ;-)
(02-27-2009, 02:28 PM)kosmos999 Wrote: [ -> ]Hi,

First, I've already checked previous threads in order to find an answer (just a topic that mention the same problem without answer)...

In Tales of the Abyss I've got huge FPS drop on some cut scenes/villages : 60 to 10 FPS.
The issue appears only in some villages (ex : in Keterburg or in engeve)

Otherwise, the game runs great at 60 FPS the whole time (Fights,Map and the main part of the villages of the games).
I've turned all speedhacks on exept the 1.5x, 2x or 3x options (these options solw the game in general)

I use PCSX2 PG r528, and GDSX9 (Winxp) (SSE4.1) 0.1.14 on a [email protected], 2Go pc8500 and a ATI HD4850.


I've tried, ZeroGS plugin :Fps are stable around 60fps whole time but I have artefacts (I've tried a lot configuration without success).
I also tried to configure pcsx2 and gdsx in differents ways but it keeps ending on the same issue whatever the configurations I use.

Thanks by advance ;-)

I have the same problem as well. My guess is that it is the way ZeroGS and GSDX are coded. Speed hacks doesn't really do anything. For GSDX, the slow down usually happens when there are a lot of models on the screen (i.e. Baticul, Grand Chokma, etc.). On the other hand, ZeroGS slows down when there are a lot of effects on the screen (i.e. Mystic Artes, Fonic Artes, etc.). Right now, the only way to get your full 60fps is to use DX10 (Vista) version of GSDX. Other than that, there's not much you can do other than wait for gabest to release a new GSDX that will hopefully fix that issue.
Edit: I am not sure about this until an nVidia card owner confirm this, but it could also be an ATi driver problem (I have an HD4800 as well). Again, I'm not really sure until someone with an nVidia card and running XP confirm this.
I get 60-70 fps constantly. Specs in sig. My config:
Latest rev of the emu, any of the recent ones will work
Newest GSDX rev and SPU2-X rev
GSDX- DX10 Hardware, 1024x1024 res, 16:9, NLOOP Hack gray check, Texture Filtering black check
MTGS on, frame limiter 70 fps
INTC Hack on, 1.5x cycle rate, IOPx2 Hack on, WaitCycles Sync hack on
EE Recs/VU Recs (same settings)- Round Mode Chop/Zero, Clamp Mode None, FtZ and DaZ checked

Try using something close to that as possible that. Your problem may be that you lack Vista (meaning you lack DX10). If so, sorry but that can't be fixed unless you get Vista.
I'd rather say it's the ATI problem. See if software rendering is significantly faster in those areas. If so, then you know what's wrong Tongue2
Or probably Hd4xxx. Problem like someone got only 30fps in game FFXII in other thread. For me is No because i have Ati HD3870. Try program ATI Tool to set fix core clock reGadless autoclock switch between 2D and 3D running.
Or if you dare to try (not recommanded for noob), get RBE program to open bios ATI, to set certain clock GPU and ram, include volt gpu and ram for 3/4 different state like i already did. Then flash bios moded to your grapich card.
Try setting native internal resolution and see if it helps.

I find in tales of the abyss, using even 1280x960 internal resolution will cause my FPS to drop slightly to 45-50 during some spammy mystic artes so I use 1152x864 instead to get a solid 60fps.

This is on a HD4850 @ 800/2200mhz.
@Elanzer
Tried that, it's not a matter of internal res. Even with native, there are spots in Abyss that causes the fps drop. The biggest drop happens in front of Grand Chokma castle. I also tried software with 2 threads (4 will drop fps to ~5, even with quad core). The result is 5-8 fps increase.

@Register
Regarding FFXII, I can play it just fine with stable fps. The only exception would be when Basch uses "Flame Purge". Both GSDX and ZeroGS drops to ~10 fps.

@rama
So, since software doesn't increase fps by that much (5-8 fps). Is it safe to conclude that it is a dx9 vs dx10 issue?Tongue
"...Is it safe to conclude that it is a dx9 vs dx10 issue?"

I think so.
I'll try it on vista later (I have to install it before) and I will keep you informed...
So, I've tried on vista and gsdx10 and it works great !

No more fps drop so it was a gsdx9 issue and not an ATI one.

I've also tried TotA on 0.9.6 but I cannot go to full screen no matter the fullscreen resolution I choose.

Does anyone got a clue ?
Pages: 1 2