..:: PCSX2 Forums ::..

Full Version: [Bug Report] Final Fantasy X-2 [PAL]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
First post, so Hello everybody.

The problem in FF X-2 is the same as in the others FF.

The game has been tested without speed hack and with both GsDx and ZeroGS plugins and Advanced options set to Default (DirectX 9.0c under XP)
*Using pcsx 0.9.6
*Cpu eerec on, vurec0 and vurec1 on, MTGS on

Using MTGS mode and ffhacks from ZeroGS 0.97.1 or NLOOP hack from GsDx 0.1.14 is useless, there's still missing textures.

On an other post a pcsx2 coders (forgot his/her name, sorry Blush) asked for the CRC. Here it is for FF X-2 Pal :

CRC = 9AAC530C
Game code = SLES_518.16

Hope that I didn't make a double post because that subject has already been taken in consideration.

PS :I'm from Belgium, so don't pay attention to my fault in English (Or correct me if it's catastrophic Laugh)
what colour is the nloop "tick" in the options? make sure its black if you are still getting issues. also make sure you dont use pixel shader 2, for some reason that one has always still had holes. It may be MTGS mode still has holes due to the emulator controlling this "hack", so we will need to know the CRC of your game to enable it.
the nloop tick is black, and I use pixel shader 3. I've tested all the nloop different "ticks" and tested using logarithmic-Z ticked too(with or without). I still get the same problem when MTGS mode is ticked. Without MTGS mode, FF X-2 works fine but is too slow.

all tests has been made without speed hacks.

the CRC is 9AAC530C
Game code = SLES_518.16

Hope it will helps
revision 715 should solve it for you Smile
And does it solve it? Smile
Sound perhaps like a stupid question, but where can I find the version 0.9.6 revision 715 ? and how to know which version I have?
Just wait for a new beta, I'll put one up tomorrow
Great job !!! The problem has been solved. Everything's fine now. I've tested with both plugins GsDX 0.1.14 and ZeroGS 0.97.1 and the other options set to defauld, no speed hack and there is no more problem now.

Thanks for your job !!

Edit : you can add it to your compatibility list now, fully working : Final Fantasy X-2 (French) (SLES 518.16)