..:: PCSX2 Forums ::..

Full Version: Error MSVCR120.dll. Cant be solved.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I keep getting the error MSVCR120.dll is missing.

I have the latest PCSX2 the latest Microsoft C++ from 2005 to 2012 installed for both 64 and x86) and 2013 which is only Installed for x86. They are the redistributed ones.

I also have 64bit and 32bit installed in my pc. OS is win7.

My specs:
AMD A8 6600K with Radeon 3.9GHZ. 8GB RAM.

i tried placing the dll file in the Windows System but then i started getting the error (0x000007b)So i immediately did system restore. That was close.

Anyone knows of a solution to this problem? May do i need to install an older PCSX2 version?

Or is there another emulator that is just as good?

Many thanks.
There is no other PS2 emulator.

Try reinstalling VCREDIST 2013 x86 version, and when it pops up with "Modify Setup," click "Repair."

Use this link: http://download.microsoft.com/download/2...st_x86.exe
Thanks for the reply.

I managed to get working.