..:: PCSX2 Forums ::..

Full Version: Cant run the installer for 1.3.1. version
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, can anyone help me with this problem please. I formated my laptop that used to run perfectly the installer for 1.3.1. version 86x bit (on windows 8.1). After the format (with windows 8.1 installed too), the pcsx2 installer does not run, the window simply disapears.
I tried running as administrador and the troubleshooting option but nothing works. I have a 64x bit system and the installer is for 86x bits. But I could not find any pcsx2 installer 1.3.1. for 64 bit.
Can someone help me run it as before, or point me in the right direction on finding the 86x bit installer.
Thanks in advance.
there is no installer, it's portable. just download it from here and move it to any directory as you wish and open the pcsx2.exe file to launch pcsx2.
Thanks ssakash! The other .exe I tried did not work, but the top one in the link, worked perfectly. Thanks!! Smile