..:: PCSX2 Forums ::..

Full Version: Lament of Innocence - cutscene camera stall
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Aright, best way to show, first how it normally plays, like this intro "cutscene" for both the large ogres: https://www.youtube.com/watch?v=gFMxeFrV...page#t=180

What happens to me: the camera starts in the same position as the start of the cutscene in the video, and doesn't move. Ever. The green one appears, does it's pose, then disappears (presumably occluded out as the camera should not have it in range) as the red one does it's pose. Green one reappears, and they start their normal AI, attacking and whatnot. Leon doesn't get hit, nor can move or attack, can't pause or get to any (in-game) menus, and the camera is still in that same position.

Poking around settings and trying to find something to fix it, but given how many options there are, wanna know if anyone knows what's going on and can solve it faster.
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
try disabling every speedhack and try tweaking with the clamping and rounding modes and check whether it fixes it.
Arright, lesse now;
Intel Core i7 2.67Ghz processor, Asus GT 630 2GB vid card, 8 gb RAM, Win7
And I had to switch the audio output model to XAudio 2 to get the sound working, window size from 640 to 1280 (while I'm at it, which option is it I want to bump up the resolution?) and I think that was the only two things I changed from installation defaults.
And tried both ISO and DVD.
care to post the emulog when it occurs ?
are you sure you didn't change anything in clamping & round modes ?
(04-17-2015, 09:45 AM)ssakash Wrote: [ -> ]try disabling every speedhack and try tweaking with the clamping and rounding modes and check whether it fixes it.

Hot damn, changing the clamping options fixed it--- any of the ones BUT normal; None and Full both, and "Extra + Preserve Sign".
So, what's clamping do, and for the rest of my gaming experience, which would I want?
And the log thing--- that other window that opens when I boot up PCSx2, yeh?

Quote:PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8183 MB
CPU name = Intel® Core™ i7 CPU 920 @ 2.67GHz
Vendor/Model = GenuineIntel (stepping 04)
CPU speed = 2.659 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3bd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\gsdx32-sse2-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
Binding SPU2: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
Binding CDVD: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
Binding USB: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\USBnull.dll
Binding FW: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\FWnull.dll
Binding DEV9: X:\Downloads\games\PSx2\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 217ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
NVIDIA GeForce GT 630 (
Opening CDVD
isoFile open ok: X:\Downloads\games\PSx2\Castlevania - Lament of Innocence (USA) (En,Ja).iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1478048 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: X:\PCSX2\memcards\Mcd001.ps2
McdSlot 1: X:\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.33;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_207.33;1) Game CRC = 0x28270F7D, EntryPoint = 0x00400008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.33;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Loading savestate from slot 0...
filename: X:\PCSX2\sstates\SLUS-20733 (28270F7D).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
That savestate 0 loading just before the end, that's at just before the door before the cutscene in the video. Also tested if going from the last in-game savepoint--- that save-file was a transfer from my actual PS2, but don't think it's relevant, save for I then don't know if it would have gotten stuck during the intro cutscenes.... hmmm, let's see.
Quote:X:\Downloads\games\PSx2\Castlevania - Lament of Innocence (USA) (En,Ja).iso
anyways you're on your own, now.
thread closed & have a warning for piracy