..:: PCSX2 Forums ::..

Full Version: Yakuza black screen problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I'm playing through Yakuza 1 and having a blast, but there's a massive problem.
Sometimes when I talk to people or enter a new screen/building, the screen turns completely black.
The HUD is still visible, there are sounds, and the game still recognizes input.

So basically, everything is exactly the same except the screen is black so I can't play.
This has gotten worse and worse the further into the game I get and it's gotten to the point where the game is basically unplayable.

I'm using the latest version of PCSX2 (1.2.1, the official release from the website), only recommended speedhacks and native resolution.
Switching back and forth from software mode doesn't make a difference whatsoever.

I google'd the problem and found a code.google page where they said that r5843 was supposed to fix the problem, but I cannot for the life of me fix that issue.
Could someone help me locate it or point me to another revision that fixes the issue?

Thank you!
It said hopefully solved the hangs, I guess it didn't, where abouts does it happen?
Sometimes when I talk to people or enter a new screen/building. Quite frequently, actually. It seems completely random, but I've seen it a lot in the batting cage.
try the newer git builds
please provide the content of your emulog during the crash instance.
Quote:PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft (build 9200), 64-bit
Physical RAM = 5962 MB
CPU name = Intel® Core™ i5-3230M CPU @ 2.60GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 2.592 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7fbae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx-r5875.dll
Windows 6.2.9200
Binding PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll
Binding FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 217ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
Intel® HD Graphics 4000 (
isoFile open ok: C:\Users\Oskar\Desktop\GAMES\Yakuza (USA).iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2144000 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Oskar\Documents\PCSX2\memcards\my memory card.ps2
McdSlot 1: C:\Users\Oskar\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.48;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.48;1) Game CRC = 0x388F687B, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.48;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Loading savestate from slot 0...
filename: C:\Users\Oskar\Documents\PCSX2\sstates\SLUS-21348 (388F687B).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
MTVU speedhack is enabled, saved states may not be stable
[15:58:54.543] Auto-ejecting memcard [port:0, slot:0]
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Intel® HD Graphics 4000 (
Forced software switch enabled.
Loading GS
[15:58:58.324] Re-inserting auto-ejected memcard [port:0, slot:0]
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Intel® HD Graphics 4000 (
Loading GS
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.

I went into the game, put it on software mode, walked around and talked to people until it happened, then switched back to hardware mode to confirm it wasn't working and then closed the emulator. Then the log looked like that.

...That IS the emulog, right?[/quote]
If that version doesn't fix it then, try the latest development versions from here.
So it was fine in software mode? This is more likely to do with the fact you're using on-board graphics then, I suggest you upgrade your drivers from Intel and maybe try putting gsdx in dx9 mode
I tried "v1.3.1-379-g2704a65".
And it seems to be working!

I'll get back to you if it starts acting up again, but for now, problem solved. Thank you, and sorry for the trouble. ^^'
You were using savestates. Additionally in combination with speedhacks. This might be the explanation why this error happens more and more often while you proceed in the game. I guess every time you had a black screen you pressed F3?

As always: as long as you observe emulation errors don't use savestates.