..:: PCSX2 Forums ::..

Full Version: Having problems geting cheats to work in game
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I know what you're thinking...OH God another newb.  But i have been playing emulators for years....I have even had PCSX2 and this game rom for years but when I first got them, I never had a PC which would run the emulator well enough to make the game playable...now I finally did.  The game, Final Fantasy X.  I bought a copy of this game not long after it came out and started playing it on my PS2 but never got to finish it due to moving...and I then later moved out of the US to Europe where I live now and I was not able to bring my game or PS2 with me.  I think my mom still has them all at her house though.  Anyway, the game running fine on my current laptop so I thought I would play around with it some more.  I found some cheats that someone else had put together, but they had more codes than I wanted...I only wanted a few so I made my own file by copies the codes I wanted from thiers...and removing the // in front of the actual codes of course.  But it isn't working.  The codes claim they are for the American Region of the game.  I have had this ISO of the game for years now waiting for me to get a PC that would run it...so I don't remember which region it is supposed to be but I find it hard to believe (knowing myself) that I would have obtained an ISO that was not the American Region.  At any rate, I believe the game HAS to be either American or PAL because the langage in game is English, both the voice overs and the captions.    So why aren't my cheats working? 

I tried making my own with an online tutorial I found but ran into problems from the start.  I have experience using Cheat Engine, I already had it on my PC and use it on a PC game I have.  But I ran into problems right from the beginning.  The Values I am dealing with are relatively small...less than 1,000 in value so only tree digits long.  If i try to search for the value's with a value type of 4 bytes, it finds it but always finds two.....  If I change the value type to 8 bytes which the tutorial I was reading used...it doesn't find the value at all after I preform the next scan.  So anyway, I don't really know what to do now.  Any help would be appreciated.
OK so I went back and ran the ISO in PCSX2 then had a look at the log. This is what the log says:

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_504.90;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL

So apparently my ISO is a PAL region and not from the US...is this why my cheats are not working?
you mean the game you bought in US, but it's a PAL version ?
I wonder how it could work on your US PS2, then...
where did you get those codes ?
(01-14-2016, 10:12 PM)jesalvein Wrote: [ -> ]you mean the game you bought in US, but it's a PAL version ?
I wonder how it could work on your US PS2, then...
where did you get those codes ?

No, sorry for the confusion.  No I bought a copy of the game when it first came out in the US and started playing the game but never got to finish it because of my move.  My game as far as I know, is still in storage at my mothers house.  I found the ISO I am currently using on the internet. 

I found the cheats on this very forum:
Quote:I found the ISO I am currently using on the internet.

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.