..:: PCSX2 Forums ::..

Full Version: Kingdom Hearts 1 slows down in certain custscenes and only in hardware render mode
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
System specs

Skylake core i3 3.8ghz dual core with hyper threading
intel 530 graphics (4600 )
8GB DDR4 @3333mhz 
Windows 10 64bit

In the destiny island cut scene when reiku is speaking the game slows down to a crawl. This is with opengl and direct3d11 plugins. It doesn't matter what resolution I set or what presets I use for emulation. Outside of those specific instances in the cut scene, the game runs flawlessly at 60fps with any combination of settings.  Other parts of the same custscene run perfectly. 

If I switch to software rendering everything is fine, even at the highest possible software rendering settings. 

Based on the recommended system specs I should be fine. My CPU is more than comparable to 3.0ghz core2 era quad cores and the intel 530 integrated graphics are much faster than the recommended 8800gt, especially when paired with high performance memory like I have. In my bios, I set the shared memory with graphics to the maximum (1024MB) so I shouldn't be VRAM throttling either. I am stumped. 

Anybody run into this problem? Any ideas? Thanks Smile
the sunset scene n destiny island is slow for everyone in hardware mode.
nothing you can do atm
(02-24-2016, 08:29 AM)jesalvein Wrote: [ -> ]the sunset scene n destiny island is slow for everyone in hardware mode.
nothing you can do atm

Thanks, I searched but couldn't find any info. Is that the only cutscene that is slow, or is it a problem throughout the game?
AFAIK, it's the only one.
The game likely reads the content of the rendered buffer to emulate a special effect. However, if you want to do a GPU->CPU transfer, you need to flush all your GPU commands (around thousand of commands, potentially it is several frames). Then you will have to wait the transfer which are often slow in this way. So the latency is very big, therefore it is very slow.