..:: PCSX2 Forums ::..

Full Version: Shin Megami Tensei Nocturne Z depth issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Sorry if this is a known issue, I've searched for quite a while and found no solutions that work for me.

I'm trying to run Shin Megami Tensei Nocturne / Lucifer's Call (PAL). The problem is that some characters and objects appear on top of things that they should be behind. It appears fine in software mode, but is too slow to play. The game runs perfectly so far in hardware mode other than the Z depth problem.

Screenshot of the problem is attached.

My specs are in my signature, here are my PCSX2 settings:
PCSX2 rev 1621

CPU Config:
EERec on
VU Recompilers on
Frame Limiting set to Limit

Speed Hacks:
x1.5 Cycle Rate
INTC Sync Hack on
IOP x2 Cycle Rate on
Idle Loop Fast-Forward on

Round Modes - Chop/Zero
Clamp Modes - None
Flush to Zero both on
Denormals are Zero both on

GSDX 1600 SSE2:
Direct3D10 (Hardware)
Texture Filtering on
Allow 8-bit textures on

- I have also tried Direct3D9 (Hardware) with Logarithmic Z both on and off.
- I've tried PCSX2 1474
- I've tried both PAL and NTSC modes (both are available on my copy)
- I've tried changing the Advanced settings around

Thanks for any help.
Try updating your GSdx, it should work fine then, there were just a few revisions that had this problem

And if it's still the same use an older one, GSdx 0.1.14 should work fine for example Tongue
Thanks very much, GSDX 890 works fine (except for the shadows through the character's feet, but that's not a big issue). I tried 1650, but it still had the Z depth problem.
Uhm, works fine for me maybe a problem with your game version, good thing there's various GSdx versions to choose from :P (If im not mistaken r1406 was the last working version for it in your case)