Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
0.9.8 settings query
#1
I'm using PCSX 0.9.8 to play FFX International. I have searched the forum for every thread pertaining to FFX and read the stickies. A lot of the information I found was either outdated (for 0.9.7, where a lot of the settings are different) or pertained to specific hardware. I was wondering if you more experienced users can see any settings that are blatantly wrong for my system.

My PC:
Windows 7 64bit
AMD Phenom II X4 945 3gig Processor
Nvidia GeForce GTX 260
4 gigs Ram
Monitor native resolution 1360x768
XBOX 360 Controller (wired)

My PCSX 0.9.8 settings:
Emulation Settings

Speedhacks - Enable speedhacks [enabled],
EE Cyclerate [1],
VU Cycle Stealing [0],
Other Hacks [all 3 checked],
microUV hacks [both checked]
Game Fixes - FFX videos fix [enabled]

Plugin/BIOS Selector
GS - GSdx 10 (MSVC 15.00, SSE2) 0.1.4 [GSdx10]
PAD - LilyPad svn 9r4510) 0.10.0 [lilypad-r4600]
SPU2 - SPU2-X r4600m 1.4.0 [spu2-x-r4600]
CDVD - Linuz Iso CDVD 0.9.0 [cdvdiso-r4600]

BIOS - 70012 V12 USA

Config
Video (GS) plugin settings -
Resolution [Windowed]
Renderer [Direct3d10]
Interlacing [None]
Aspect Ratio [4:3]
D3D Internal Res [1360 x 768]
Texture Filtering [checked]
Enable NLOOP hack [checked]

Audio (SPU2) plugin settings -
Interpolation [2-Cubic (artificial highs)]
Disable Effects Processing [unchecked]
Reverb Boost Factor [1x-Normal Reverb Volume]
Enable Debug Options [unchecked]
Module [1-XAudio 2 (recommended)]
Latency [150 ms (avg)]
Synchronizing Mode [TimeStretch (recommended)]
Audio Expansion Mode [Stereo (none, default)]
Use a Winamp DSP Plugin [unchecked]


The game is running off of an ISO very smoothly in fullscreen at a high resolution 90% of the time, with the following issues:
Occasional random audio lags that are not attached to any specific spell or visual effect.
The FMV sequences sometimes flash and stutter until I enter the Video Plugin Settings and leave again.
In-game screens (TV screen in the bar, for example) don't display properly.

The official configuration thread for 0.9.7 was a lot of help getting the basics set up. If you guys can help me tweak it to perfection, I'd be very grateful. Can you see anything obvious that I should change?
Reply

Sponsored links

#2
Issue 1: Are you running at full speed during the slowdowns? If not, does this happen on native resolution?
Issue 2: Does this happen on native resolution?
Issue 3: Check if your skipdraw value is 0; this can be checked in the gsdx.ini file in the "inis" folder of your PCSX2 installation folder. If setting the value to 0 doesn't fix it; what do you mean "not displayed properly"? Not showing up at all? Corrupted graphics?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
You're using a very old version of GSdx, try at least with GSdx r4600
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Thanks for the help. I've updated my GSdx and set it to native resolution. Unfortunately it didn't help (much). My GS plugin now reads
GSdx 4600 (MSVC 15.00, SSE2) 0.1.16 [gsdx-sse2-r4600].

Issue 1: My framerate dips with it, down to the 40's. Happens less in Native resolution, but still happens.
Issue 2: Still happens, even in Native resolution. When a FMV begins, the final frame of the game from immediately before the cutscene keeps flashing over the FMV.
Issue 3: My GSdx-sse2.ini does not have a "skipdraw=" line. Should I add it? By "not displaying properly" I mean that the screen in the bar was displaying a corrupted image - the image was staggered, in strips, like it had been through a paper shredder and glued back together wrong. Still happens in Native resolution.
Reply
#5
click here to see one of the configs ive used. FFX works perfectly fine for me (mine is the Australian PAL release, which basically is international Tongue). i dont have any of the issues your experiencing, and the only time FPS dips for me is when Demi as cast, which seems to happen for a lot of people, and my system is weaker than yours. for the GDsx plugin, in the interlacing option, i usually use blend tff, and usually have no problems.

this was back when i was using the official 4600 release found on the main site, and using the plugins that came with the emulator.

also, in regard to gamefixes, i find its better to just leave manual gamefixes turned off, and leave the automatic gamefixes on, found by going system -> automatic game fixes.

and on another note, im not 100% sure on this one, i see your using SSE2, but i have heard that if your system supports SSSE3 or SSE4.1, its generally better to use them instead (SSSE3 if you dont have 4.1 support, but if you do then use SSE4.1)
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#6
The new versions do not have the patches do? Suikoden Tactics plays only a patch to switch videos. I'll see if it was just the first video that has caused problems and use 0.9.8.
Reply
#7
(08-15-2011, 08:30 AM)seniyajw Wrote: The new versions do not have the patches do? Suikoden Tactics plays only a patch to switch videos. I'll see if it was just the first video that has caused problems and use 0.9.8.

ummm... why create a new account and post that here... it was already posted with a response here...

and yes, im assuming that youve made a new account, since that post is almost the exact same as the one in the thread i linked...
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#8
Issue 2: Switching to DirectX10 Software mode fixes the FMV problem, at the loss of my framerate (and resolution). Sad
Reply
#9
software mode requires a much more powerful CPU since the CPU is also doing the graphics rendering. There will be less graphical errors, but a fairly big performance hit.

did using the settings i posted earlier help in any way, or have you not tried them yet?
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#10
(08-15-2011, 12:46 PM)Dante3hs Wrote: software mode requires a much more powerful CPU since the CPU is also doing the graphics rendering. There will be less graphical errors, but a fairly big performance hit.

did using the settings i posted earlier help in any way, or have you not tried them yet?

I tried them immediately, they allowed me to run the game almost perfectly at 2x native resolution, but they do not solve the FMV problem.

Regarding the SSE2 settings, according to the link in the stickied Official Configuration thread, my system only supports SSE2.
Reply




Users browsing this thread: 1 Guest(s)