Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
60fps on "2D" game
#1
I open the post again, because old was closed without any solution to my question

Copy/paste the old post


Hi!  i have a small question

Im using latest pcsx2 1.4 on XP 32bits, my PC is a dual core 3ghz, intel GMA x4500, 2Gb ram, DX9 "Software" plugin


Im testing King of Fighters 94 rebout,  and get some slowdowns on menu and videos  35-45fps, but ingame i get a  solid 60fps

I believe that maybe is too much for my CPU,  then i open the task manager, and check CPU usage....


Ingame = 60fps - CPU usage  60-80%
Menu-Video = 35-45fps - CPU usage 55-75%


Any ideas why even if CPU usage is slight lower in menus and videos,  im still get slowdown?


Thanks
Reply

Sponsored links

#2
You did get an answer, and you rejected it. Subsequently your thread was closed because it seems that you didn't care for legitimate answers.

TLDR: Your GPU is old and outdated, and you reject that as being the cause of your issues, so your thread gets closed.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(01-23-2017, 01:27 AM)Nobbs66 Wrote: You did get an answer, and you rejected it. Subsequently your thread was closed because it seems that you didn't care for legitimate answers.

TLDR: Your GPU is old and outdated, and you reject that as being the cause of your issues, so your thread gets closed.


I just read here...

https://github.com/pcsx2/pcsx2/issues/455

Quote:In short you don't need a good GPU but you do need a good driver Smile




To confirm I plug in the PC a most powerful GPU, a nvidia GTX, and no difference at all in software mode... Im still get same results in menu and videos
Reply
#4
Then why don't you switch to hw mode if you have "a most powerful GPU, a nvidia GTX" and use OGL mode?
Reply
#5
(01-23-2017, 01:49 AM)vsub Wrote: Then why don't you switch to hw mode if you have "a most powerful GPU, a nvidia GTX" and use OGL mode?


Because I use a Dell USFF for emulation,  and this machine dont have any PCIE port.

I just tested in another PC i have in home, that have same GPU, using the CPU of the dell




If in software mode the CPU usage is 100% i will not get surprised to get slow fps, it means my CPU is not powerful....  but is not the case, the game run great all the time with 60-70% CPU,  and just videos and menu are slow... with similar cpu usage
Reply
#6
What does the EE and GS in the title bar of the game windows say during those slow downs in HW and SW mode
What are your GSdx and PCSX2 settings and what exactly is your CPU..."dual core 3ghz" doesn't say much
Reply
#7
(01-23-2017, 02:11 AM)vsub Wrote: What does the EE and GS in the title bar of the game windows say during those slow downs in HW and SW mode
What are your GSdx and PCSX2 settings and what exactly is your CPU..."dual core 3ghz" doesn't say much


Ah sorry, you right, i forget to write the correct CPU type,   is a C2D E7600


Ok what do you asked


- during the slowdowns in the menu -     EE:30-36%   GS:34-40%    fps:42-45%     in taskmanager the CPU usage is 60-70%

- Ingame -  EE:28-38%  GS:37-45%   fps:59-60     in taskmanager the CPU usage is same, around 60-70%




I already try:  speedhacks on/off,  all options inside speedhacks one by one, and all presets.... no much difference



thanks
Reply
#8
Hmm no idea but the cpu us on the slow side
When you switch to Software mode,change the rendering threads to 2 and disable the MTVU speedhack
Reply
#9
(01-23-2017, 02:48 AM)vsub Wrote: Hmm no idea but the cpu us on the slow side
When you switch to Software mode,change the rendering threads to 2 and disable the MTVU speedhack


Hi thanks, I already have rendering threads in 2, and no MTVU hack active

To add more info, i tested the original game, and i make a ISO, no difference



I dont know what can be the problem, specially because all other games i have plays great, Capcom vs SNK 2, Hokuto no Ken, KOF98, some japanese talking adventures... all  60fps, videos, ingame, etc



Is just this game, and in menus only... but is my favorite game, i really want to find what is the problem...
Reply
#10
Some good news for me,  finally i found a way to have constant 60fps even on menus and at same time, fix one of the more annoying things in KOF94 rebout,  the difference of resolution within backgrounds and character

I create a resolution of 640x224 at 120hz, and disable vsync in the emulator.  This solve the problem of fps in menus and no tearing at all


And second, now backgrounds and characters have scanlines..... perfect.  OF course i lost resolution, from 640x448 to 640x224 but still looks much better than original KOF94


[Image: 1.jpg]

[Image: 2.jpg]

[Image: 3.jpg]
Reply




Users browsing this thread: 1 Guest(s)