Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any additional suggestions for slowdowns?
#1
I've downloaded the newest 0.9.7 and am liking it a lot. I've only played one game on it yet (Legaia 2: Duel Saga) and for most of the time it is staying right around 60 FPS. During some parts in the game, specifically the first town (Nohl) and Jinga, the island of the giants, as well as during many dialog scenes, the FPS slows down to ~50 FPS and sometimes down to the low 40s. While this is annoying, it is definitely still playable.

The thing I've noticed now with 0.9.7's ability to display the EE usage, is that during these slowdowns, the EE usage shoots to and remains at 99-100%. I don't notice any particular change in GS usage, however. I have the internal resolution set to 1600x1120, which is 2.5x native. Setting it higher causes more slowdowns, but setting it lower or even to native doesn't have any effect on them. MSAA is off since it adds a bunch of lines to the dialog boxes. Interlacing settings don't have any impact on performance, either. Here are my other settings:

                       

The only speedhack that has a noticeable impact on the game's performance is "Enable INTC Spin Detection". Without it checked, it basically subtracts ~5 from the FPS whether there is a slowdown or not.

My computer has:
OS: Windows 7 Professional x86
CPU: AMD Phenom II X3 720 AM3/AM2+ 2.8GHz Black Edition
RAM: Corsair 4GB (2 x 2GB) DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB PCIe 2.0 (with latest drivers)

As far as PCSX2 settings, is there anything else anyone can think of for me to try? As far as my computer, nothing in it is overclocked. Based on the probable cause of the slowdowns and the spike in EE usage, which components might help these slowdowns to diminish by being overclocked?
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply

Sponsored links

#2
EE being at 100% indicates the main emulator is being limited by your CPU (graphics plugin is rarely at fault in these cases). You could try putting VU Cycle stealing up to 2 or so notches, that may help speed things up a little. Other than that, there isnt much short of overclocking you can do im afraid Sad
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
try putting both clamps to NONE (this will break some games or cause problems in others) and also try using superVU (its faster in some games but less compatible)
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#4
(06-03-2010, 02:56 AM)refraction Wrote: EE being at 100% indicates the main emulator is being limited by your CPU (graphics plugin is rarely at fault in these cases). You could try putting VU Cycle stealing up to 2 or so notches, that may help speed things up a little. Other than that, there isnt much short of overclocking you can do im afraid Sad

Thanks for the reply. Setting the VU Cycle Stealing to 1 makes no noticeable difference. Setting it to 2 keeps the FPS around 60 all the time, even during the slowdown times. However, the EE seems to be in the high 80s and 90s during all the normal speed parts and drops down to the 70s during the slowdown parts. Also, the slowdowns are worse and it even adds some slowdowns where there were none, all with the FPS reporting ~60.


(06-03-2010, 03:07 AM)iakoboss7 Wrote: try putting both clamps to NONE (this will break some games or cause problems in others) and also try using superVU (its faster in some games but less compatible)

Thanks. Clamps to None don't make a difference, but using superVU for both VU0 and VU1 increases the FPS during the slowdowns by about 6-7 FPS. So with these settings, the slowest it ever gets is ~46 FPS.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#5
Okay, I tried overclocking it from 2.8GHz to 3.3GHz by increasing the multiplyer and the slowdowns are dramatically better. The slowest I saw it get to was ~56 FPS. I wonder it 3.4GHz would make it at ~60 all the time. I only have a stock heat sync and fan. I've read around that you want to keep your CPU temperature under 55 degrees, so I'm not going to be increasing the voltage to get some higher stable frequencies. I'm going to run Prime95 for a while to make sure 3.3 and 3.4 are okay. Is this a good plan? Is there anything else I should know?
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#6
you should be sure ALL voltages are on stock numbers and the maximum temp doesnt get beyond 70 (it can handle 80 probably but better not Tongue )
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#7
Yeah, all voltages are on stock. I reset all the BIOS settings to default and ONLY changed the multiplier from 14 to 16.5. I plan on increasing it to 17 if the temp is fine and prime95 can run for hours on it.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#8
Basically, if you do not increase the voltage, your CPU does not get much hotter. But, I suggest you try to determine the real, minimal voltage your CPU needs for the desired clock and set it straight in the BIOS. Auto voltage tends to over volt the CPU on many mainboards. For example, if CPU voltage is on auto, my Athlon II gets 1.4v, even at stock speed, although it runs flawlessly with 1.3v overclocked. 0.1v is a HUGE difference.
Intel i5 3450
AsRock B75-Pro3-M
Sapphire R9 290 Tri-X OC
8GB DDR3-1333 RAM
Sandisk Ultra Plus 256GB
Seagate 7200.14 1TB x2
Enermax Triathlor 450W PSU
Reply
#9
(06-03-2010, 09:09 PM)Idec Sdawkminn Wrote: Yeah, all voltages are on stock. I reset all the BIOS settings to default and ONLY changed the multiplier from 14 to 16.5. I plan on increasing it to 17 if the temp is fine and prime95 can run for hours on it.

when i said stock i didnt mean auto Tongue as samsonight said you must put the stock numbers not just let it as it is....
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#10
Thanks. I'll be using the AMD Overdrive utility now. I'll set the voltage to the default one.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply




Users browsing this thread: 1 Guest(s)