Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any way to fix the line issues with 2D games?
#1
So far I know changing to software rendering fixes the graphics issues but then the games tend to run terribly. Setting Unlimited Saga to DX11 hardware and 2x Scaling has given me the best reduction of lines so far (not noticable in combat, mildly so in menus and area traversing). However in Growlanser the lines are still very very prominent and even cut up character art due to animated mouth movement being a separate sprite usually.

Is there a reliable way to cut this down or is it just something to deal with?

Running a 955 BE 3.2, 5870 and 8GB DDR3 and I'm on 9.7.4169 build.

Also Unlimited Saga slows down when I get a combo reel of 4 or 5 moves in combat, is this just from a hardware limitation?

http://i.imgur.com/goCDf.png set for 5x
http://i.imgur.com/Gbg0D.png Set for native
http://i.imgur.com/vtSEo.png Set for 2x but I think it's using a custom res

Pictures related for different settings, open to suggestions on what resolutions to set. Ok nevermind on the reel slowdown, I guess the new graphics setting I'm trying now also improved performance since my combat hasn't lagged at all with it.
Reply

Sponsored links

#2
actually, svn versions aren't supported. try with latest official beta
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Oh it's an SVN? I'd just downloaded one of the more recent betas a few months ago.

My memory cards and save states will work between versions right? I'll try with the latest beta but I'd still like to know if it's possible to fix the line issues on 2d games, since older versions of the emulator had it as well.
Reply
#4
memcards will work without much of a problem, the save states are incompatible between many versions/revisions.

You're experiencing glitches from using resolutions the games were not desgined for, "Native" in a (Hardware) renderer and a (Software) renderer are the most compatible, not much you can do about it.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Yeah I think my custom resolution was from me trying to figure out the most accurate output of a PS2. It does cut down on the lines more than even native does. Can just make a hardsave and carry over revisions and see how another works then.

Still open to any other resolutions others might have tried before with 2D games.


EDIT
Welp solved that too. I didn't realize the resolution the plugin asks for above your DX settings on initial boot was supposed to be your monitor's screen size. I thought it was asking for my preferred window size to emulate. Changed that in the GSdx.ini to my monitor's resolution and now the game window resizes without issue.

Maybe that could be cleared up a bit in the next official release? lol

Also What are the emulator's keyboard shortcuts? I know f6 switches between custom, 4:3 and 16:9 and F8 is screenshots but not much else.
Reply
#6
There is no "resolution the plugin asks for above your DX settings" in PCSX2 0.9.7, you were either using an old version or something and the setting would not work while running in the 0.9.7 version anyway.

[Image: wuc3X.png]
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
It was on the first time setup.
[Image: EwWIu.jpg]

And yes this is the latest Beta, I get the new menu after filling that one out. The new one doesn't have the resolution setting option and I had to edit the .ini file to set it right once I realized that.
Reply
#8
As I said already, it won't make a difference when using it with the 0.9.7 beta anyway, it is now controlled under the "GS window" panel in PCSX2 settings and that's why it is removed from GSdx so it doesn't need clearing up since it won't even appear there once you're finished configuring. The only setting that changes anything from GSdx now is the scaling/custom internal resolutions.

Edit: And please try not to quote the post right before yours when not necessary Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
The option you select in that drop down is not the size of the window of the emulator. It is asking the size of your monitor. The image at the top showing DX9 is because I simply hadn't selected 11, it changes as you select versions as you should know.

However, I thought it was asking for the desired emulator size and selected 1280x960. Because of this whenever I set my custom window size to that in the GS window (since it was still 640x480) the emulator would not resize to that, as it was the same as what it thought my monitor was and it simply would not fit including the windows border so the game ignored it.

Thus I change the settings in the .ini file (which were still 1280x960 as I selected, regardless of what I had set in the GS Window screen) to 1920x1080 and then the emulator resized to whatever I set in the GS Window panel without a problem. I also realize the Hz is asking for your monitor's refresh speed.


To put it simply that option still shows up, that option is not explained clearly and that option DOES still affect the beta with no way to modify it in the options menus as it stands. One has to go into the .ini file for the plugin to edit it if they need a different setting later.

[Image: 2jSQu.jpg]

I have no problems with the window resizing, at this point I'm just explaining it so the developers can see this problem and work out a solution in future releases. Also staying strictly on a scale of the native resolution seems to eliminate lines. For US it's 512x448, so 1024x896 works wonderfully.

My only question left at this point is keyboard shortcuts for the emulator since I still haven't found any.
Reply
#10
That option does not affect the current official beta and I bet it's only showing because you messed with the .ini, how exactly is it affecting anything for you? what does it do for you? Tongue2


As for shortcuts, pretty much this:
http://forums.pcsx2.net/Thread-Keyboard-...#pid135721
There's also the Tab key to enable/disbale Turbo limiter and Shift+Tab to enable/disable SlowMo limiter.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)