Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio out of sync on Xenosaga 1
#1
Hey guys i have this problem with Xenosaga 1 audio.

During the cutscenes the audio goes out of sync, the audio goes playing strong but since the game is very demanding the FPS drops sometimes and because of that the audio part usually ends before the graphical part and all i see is the characters moving around talking but no audio.

When i play other demanding games such as Star Ocean 3 i notice the audio slows down when the FPS drops so it doesnt go out of sync.

Is there any way to slow down the audio parts on xenosaga 1 so it doesnt go out of sync?

Running the game on
gsdx 0.1.14 SSS3
P.E.Op.S SPU2 1.9.0 (tried the others too)
Linuz ISO

3x Speed Hack and all other 3 active (disabling speed hacks didnt seem to help)
C2D E6420 @ 2.9ghz
2GB 667mhz ram
GF 9800 GT
Vista ultimate
Reply

Sponsored links

#2
With SPUX-2 it will slow down. Speedhacks could screw with it, tough.
| i7 860 2.8@4ghz | Scythe Mugen 2 Rev.B | Asus Maximus Formula III | G.Skill Ripjaws 4 Gigabyte | 570 GTX AMP! | Enermax 720w PSU | X-Fi Titan | OCZ Vertex 120 GB |
Reply
#3
Cool i got it working reducing the speed hack and using SPUX-2, thx for helping.

I also noticed the game seems to run at the same speed no matter what speed hack(EE) i use.
C2D E6420 @ 2.9ghz
2GB 667mhz ram
GF 9800 GT
Vista ultimate
Reply
#4
All you really need for Xenosaga as far as speedhacks is INTC. Adding the x hacks will either do nothing or slow it down.
///Intel Q6600 @ 3.4GHz OC'd ~Xigmatek HDT-S1283 HS/F~Nvidia GeForce 8600 GTS 256 MB~Corsair 2x1GB 1066 DDR2RAM~Windows Vista Home Premium 32-Bit\\\
Reply
#5
It's odd, on my disc my FPS is great during gameplay, no Audio lag at all. But as soon as a cutscene rolls around, despite having no fps drops, my Audio lags nearly 10 seconds behind... It's really bugging me, I've tried speed hacks, changing resolution way down to native (usually run at 3x), but the cutscenes are all laggy. Maybe I'll just have to play without them then catch up on that DVD that came with my Xenosaga II? T.T
Alienware M14X - Quad Core i5 Processor at 2.40GHz
8GB RAM
NVIDIA GeForce GT555M 3GB Graphics Card
Reply
#6
picture of your spu2x settings please
Reply
#7
   

There you go. Please tell me if I've got something wrong. Oh, it's on Async mix because otherwise FFX's sound is a bit weird.

If it helps, I can play Xenosaga 2 just fine...

EDIT: Should point out I've tried Xenosaga 1 when it's not Async, so I don't think it's that.
Alienware M14X - Quad Core i5 Processor at 2.40GHz
8GB RAM
NVIDIA GeForce GT555M 3GB Graphics Card
Reply
#8
"Async", generally does exactly that;], it tries to keep full speed of sound doesn't matter synchronization. You wrote you tried it with "not async" before, but you also used speedhacks before isn't that right?;] Both speedhacks and async mix can result in same thing. Also if you're testing the game synchronization, you cannot just change a setting and expect result instantly in the game, you have to restart it or at last reload from normal save(savestate will save the "desynchronization" as well as other bugs, soo you cannot use it for that;]).
Reply
#9
I keep starting a new save whenever. So you're saying I should disable speedhacks and Async mix and try it?
Alienware M14X - Quad Core i5 Processor at 2.40GHz
8GB RAM
NVIDIA GeForce GT555M 3GB Graphics Card
Reply
#10
Seem to have fixed it by disabling both VU Cycle Stealing and Async Mix. It's a shame, because cutscenes are a lot slower now. I guess I'll play Native resolution for this one. Or I could skip all the cutscenes and have my DVD playing on another screen? xD

But it sucks that I basically have to set a new congifuration for every game... Is there any way at all to save seperate configurations so you can easily switch between them? :3 Thanks for your help, everyone.

EDIT: At least it's playable, if a tad jumpy, even on 2x native! I can finally play one of my favourite PS2 trilogies again Laugh

Also, quick note, speed hacks plus Xenosaga 1 = not fun Tongue
Alienware M14X - Quad Core i5 Processor at 2.40GHz
8GB RAM
NVIDIA GeForce GT555M 3GB Graphics Card
Reply




Users browsing this thread: 1 Guest(s)