Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Beep/Poping Sound in FF-XII
#1
Hey guys,

I'm having this rather annoying issue with FF-XII where the music/sound-effects will play an extremely high-pitched beeping sound. I'm not talking about the old issue where running around on certain terrain would make the footsteps sounds like a beep. The beeping sounds seem to happen at the same spot in the music. Oddly, it doesn't happen every single time the song or sound effect is played but when it does happen it's always at the same exact spot in the song. I found a fix for the beeping sounds by turning off effects processing in the spu2 settings but then the beeping sounds were replaced by crackling and popping sounds.

I'm using :
-PCSX2 0.9.7.3113
-SPU2-X r3117 1.4.0
(I tried PEOPS and Zeros sound plug-ins as well. PEOPS wouldn't even play music and had terrible sound quality. Zero's plug-in wouldn't play music and cut out constantly and had terrible distortion.)
-If you need any other specifics let me know.

I spent a good hour searching for answers and had no luck. Hopefully i can get this fixed with this forum's excellent help Smile


Reply

Sponsored links

#2
Try an older SPU2-X like 1.2.0
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(09-12-2010, 12:17 AM)Shadow Lady Wrote: Try an older SPU2-X like 1.2.0

I had no luck with 1.2.0 but 1.1.0 seems to work perfectly. I don't hear the annoying high-pitched sounds and i can keep reverb on so i still get positional sound.

Thanks very much Happy

Reply
#4
No problem, enjoy.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Looks like that didn't fix it. After i closed the game and reopened it (loading an in-game save not from a savestate) the beeping was back and now it's much worse. So i closed the game, switched to 1.2.0 and now that's working but neither 1.1.0 nor 1.4.0 fix it. This is really odd. I don't understand how 1.2.0 wasn't fixing it earlier and 1.1.0 was, and now all of a sudden 1.1.0 isn't working but 1.2.0 is.
Reply
#6
You can also try the SPU2-X r3628 in the updated plugin pack I guess Tongue

http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
Try disabling reverb also, as we think that is causing the issue.
Reply
#8
Yes, he said that stopped the problem but would be better if it could keep reverb without having it.

So there's no SPU2-X version that fixes it? I could have swore :/
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
Uh no we tracked it and it's the time stretcher that causes it, so disable that Tongue
[Image: newsig.jpg]
Reply
#10
(09-11-2010, 11:15 PM)Naesio Wrote: Hey guys,

I'm having this rather annoying issue with FF-XII where the music/sound-effects will play an extremely high-pitched beeping sound. I'm not talking about the old issue where running around on certain terrain would make the footsteps sounds like a beep. The beeping sounds seem to happen at the same spot in the music. Oddly, it doesn't happen every single time the song or sound effect is played but when it does happen it's always at the same exact spot in the song. I found a fix for the beeping sounds by turning off effects processing in the spu2 settings but then the beeping sounds were replaced by crackling and popping sounds.

I'm using :
-PCSX2 0.9.7.3113
-SPU2-X r3117 1.4.0
(I tried PEOPS and Zeros sound plug-ins as well. PEOPS wouldn't even play music and had terrible sound quality. Zero's plug-in wouldn't play music and cut out constantly and had terrible distortion.)
-If you need any other specifics let me know.

I spent a good hour searching for answers and had no luck. Hopefully i can get this fixed with this forum's excellent help Smile

hey im running 1.0.0 and im getting the footstep beeping HELP ME http://www.youtube.com/watch?v=ESL0F29z96k I TRIED EVERY SETTING AVAILABLE TO ME
Reply




Users browsing this thread: 1 Guest(s)