Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C++ Runtime Error PSCX2 1.21
#1
Hi... Tries Installing PSCX2  1.1 r5873... I used the installer that comes with Dx9 and its C++ 2013 requirements. However regardless whether I have a disc in or not ... 
I get a runtime Error and it will then crash. Never had this problem before, other users had this problem a few months ago. 

OS: Windows 10 Pro 64bit
Memory: DDR3 8GB
CPU: AMD Anthlon II 2x 250 3.0Ghz 64bit
GPU: Nvidia GeForce GTX 550 Ti (Driver Version 358.50)


All PSCX2 setting are out of the box except for the controller settings and obviously the BIOS.


   

here is a list of the C++ re distributable packages i have installed... if there's anything missing can you please show me a link to the download site. In the pic  you can see that Runtime failure. there also a Thread Failure from waiting for the GS plugin that comes up after above 5 seconds if you let it hang on the Runtime failure message. 

On top of the DX9 that comes with the installer I've also intalled this
http://www.microsoft.com/en-us/download/...px?id=8109

Does anyone know what could be happening here? It was working Fine on  8 and 8.1
CPU:    AMD3+ FX8350 8 cores @ 4.2Ghz, 16 threads
Mobo: Gigabyte 990FX Gaming
OS :   Win10 Pro
GPU:  NVidia GTX 970, 4GB
RAM:  16Gb DDR3
PSU:  1KW
Reply

Sponsored links

#2
If you can start the app the c redist is installed correctly.

If you crash on game boot you need to install dx enduser runtime/redist
Reply
#3
(10-16-2015, 09:39 PM)willkuer Wrote: If you can start the app the c redist is installed correctly.

If you crash on game boot you need to install dx enduser runtime/redist

Well that's a relief I suppose... can you post a link to the correct one? I've installed the DirectX End-User Runtimes (June 2010) one which i got the link to from an earlier thread... which is the correct one to install?

Thanks
CPU:    AMD3+ FX8350 8 cores @ 4.2Ghz, 16 threads
Mobo: Gigabyte 990FX Gaming
OS :   Win10 Pro
GPU:  NVidia GTX 970, 4GB
RAM:  16Gb DDR3
PSU:  1KW
Reply
#4
I always suck at providing this link. Jesalvein for sure has the right one. I think it is this one. But as i said i have a hit/miss ratio of less than 10% i would say...
Reply
#5
(10-16-2015, 09:48 PM)willkuer Wrote: I always suck at providing this link. Jesalvein for sure has the right one. I think it is this one. But as i said i have a hit/miss ratio of less than 10% i would say...

Installed and rebooted... no change
Code:
PCSX2 1.2.1.r5873 - compiled on Feb  3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  8191 MB
    CPU name         =  AMD Athlon(tm) II X2 250 Processor
    Vendor/Model     =  AuthenticAMD (stepping 02)
    CPU speed        =  3.012 ghz (2 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  178bfbff 00802009
    x86EFlags        =  efd3fbff

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3
    MMX2  .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Program Files (x86)\PCSX2\Plugins\gsdx32-sse2-r5875.dll
    Binding  PAD: C:\Program Files (x86)\PCSX2\Plugins\lilypad-r5875.dll
    Binding SPU2: C:\Program Files (x86)\PCSX2\Plugins\spu2-x-r5875.dll
Windows 6.2.9200
    Binding CDVD: C:\Program Files (x86)\PCSX2\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Program Files (x86)\PCSX2\Plugins\USBnull.dll
    Binding   FW: C:\Program Files (x86)\PCSX2\Plugins\FWnull.dll
    Binding DEV9: C:\Program Files (x86)\PCSX2\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 287ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.2.9200
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primary Sound Driver' (Windows DirectSound)
*** Device 1: 'Speakers (VIA HD Audio)' (Windows DirectSound)
*** Device 2: 'Headphone (VIA HD Audio)' (Windows DirectSound)
*** Device 3: 'HD Audio HDMI out (VIA HD Audio)' (Windows DirectSound)
*** Device 4: 'Speakers (VIA HD Audio)' (Windows WASAPI)
*** Device 5: 'Headphone (VIA HD Audio)' (Windows WASAPI)
*** Device 6: 'HD Audio HDMI out (VIA HD Audio)' (Windows WASAPI)
*** Device 7: 'Output (HD Audio HDMI out)' (Windows WDM-KS)
*** Device 8: 'Speakers (VIA HD Audio Output 2)' (Windows WDM-KS)
*** Device 9: 'Headphones (VIA HD Audio Headphone)' (Windows WDM-KS)
*** Device 10: 'Output (NVIDIA High Definition Audio)' (Windows WDM-KS)
    Opening CDVD
isoFile open ok: D:\GameLibrary\Playstation 2\Ratchet and Clank II\ Ratchet And Clank \ISO\ Ratchet And Clank.ISO
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2057616 sectors)
    Opening USB
    Opening FW
    Opening DEV9


so either you missed ... or there's something else going on. Would changing the GS

when i enter the Plugins menu (where you you slect your BIOS) I get this strange stuff aswell

Code:
(GameDB) 9655 games on record (loaded in 276ms)
[wx] Failed to load shared library 'C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx-r5875.dll' (error 1114: a dynamic link library (DLL) initialization routine failed.)
Path: C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx-r5875.dll
[wx] Failed to load shared library 'C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx2-r5875.dll' (error 1114: a dynamic link library (DLL) initialization routine failed.)
Path: C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files (x86)\PCSX2\Plugins\gsdx32-avx2-r5875.dll

Weird....


Thanks anyway
CPU:    AMD3+ FX8350 8 cores @ 4.2Ghz, 16 threads
Mobo: Gigabyte 990FX Gaming
OS :   Win10 Pro
GPU:  NVidia GTX 970, 4GB
RAM:  16Gb DDR3
PSU:  1KW
Reply
#6
this one?
Reply
#7
can you show what plugins you're using?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#8
(10-16-2015, 10:09 PM)Nobbs66 Wrote: can you show what plugins you're using?

yes here it is....

   
CPU:    AMD3+ FX8350 8 cores @ 4.2Ghz, 16 threads
Mobo: Gigabyte 990FX Gaming
OS :   Win10 Pro
GPU:  NVidia GTX 970, 4GB
RAM:  16Gb DDR3
PSU:  1KW
Reply
#9
(10-16-2015, 10:09 PM)Nobbs66 Wrote: can you show what plugins you're using?

They're in his log last post before yours
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(10-16-2015, 10:08 PM)willkuer Wrote: this one?

Sorry.. same deal as last time... installed and rebooted.... it still shows up

Thanks
CPU:    AMD3+ FX8350 8 cores @ 4.2Ghz, 16 threads
Mobo: Gigabyte 990FX Gaming
OS :   Win10 Pro
GPU:  NVidia GTX 970, 4GB
RAM:  16Gb DDR3
PSU:  1KW
Reply




Users browsing this thread: 1 Guest(s)