Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CPU showing wrong usage
#1
I've pretty much had this problem since I started using PCSX2 so it's been there when I use all the betas of PCSX2 (currently using beta 1474) and revisions of GSdx. Basically, as you can see in the screenshot, the CPU usage shows a massive percentage which constantly changes from numbers between 130% to 670%, sometimes it even shows over 4000% and stays around that. I have no speedhacks on and my GSdx (r1611) settings are attached with the screenshot. What exactly is causing this, and can it be fixed?


Attached Files Thumbnail(s)
       
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply

Sponsored links

#2
show your CPU settings please?
Reply
#3
I tried enabling microVU0 and microVU1, didn't help.
Included Advanced settings in case that's helpful. I tried Clamp Mode on Normal, None and Full/Extra + Preserve Sign.


Attached Files Thumbnail(s)
       
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#4
hm.. no idea, looks normal to me.. that an svn or gabest build?
Reply
#5
hm, might be related to the cpu detection problem with some amds, i think the amd cool'n'quiet technology is responsible for this. test it with cool'n'quiet disabled.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#6
@Saiki
It's the latest official build from Gabest.

@zero29
I had a feeling it was AMD related, but that's not based on anything 'cos i don't have any in depth knowledge of this stuff. What exactly is "Cool'n'quiet"? I guess I'll google and check it out.

BTW, am I wrong in thinking this is GSdx related? I figured since it's the GSdx plugin showing the usage at the top, that would mean GSdx is what calculates that percentage.

*EDIT*
Apparently, apart from disabling it in the BIOS, setting power management to "Home / Office Desk" disables Cool'n'Quiet. My power management is already set to that so CnQ should be disabled already, and I guess that means CnQ isn't the problem. Besides, CnQ shouldn't be in affect unless the CPU is idle so it shouldn't be interfering.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#7
change ypur Power settings to "high performance" and see if it still shows up (restart pcsx2 as well)
Reply
#8
XP doesn't have a High Performance setting, that's only Vista and maybe Win7.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#9
oh crap.. I forgot that lol been too long since i touched XP lol and yes, 7 has high-performance, I use it
Reply
#10
uncheck Allow 8-bit textures, this game slower with it.
durable PC since 2008
CPU : E7200 @ 2.53 GHz 1.04 V / OC 3.7 GHz 1.36 V (390*9.5, 4GB DDR2 780)
GPU : 8600GT (GDDR3, 256 MB) / OC (750 / 900)
BOARD : GA-EP31-DS3L (rev 1.0) broken and bought a second hand one replaced
PSU : 300 W
OS : Windows 7 Home Basic x86
Reply




Users browsing this thread: 1 Guest(s)