Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cheats on linux
#1
Hello i've been trying to use cheats on linux but i get this error 

The Cheats folder ('/usr/games/cheats') is inaccessible. Skipping...

Why is the cheats folder located in a system folder, even thow there is no folders on that location?
shoulnd't it be in the /home folder, like the cheats_ws folder? i tried putting cheats on the cheats_ws folder it doesn't work

Thanks

EDIT: already a issue on github https://github.com/PCSX2/pcsx2/issues/53...-132981337
Reply

Sponsored links

#2
If you are using the PPA, then that's where the folders go since you are installing the executable into the system itself. So you have one of 2 choices, but I will only explain one since GUIis easier in my opinion...

sudo
Go to directory in question < /usr/games>
Create a new folder called cheats

That's about it.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
Thanks but its already discussed on github it will problably be changed to the $home folder
I'll try that thanks
Reply
#4
I've created the folder, no longer getting the error message, but the cheats don't get applied, i've tried with God of War ntsc and sly 1 ntsc, patchs taken from this post http://forums.pcsx2.net/Thread-PCSX2-Wid...#pid271674

Also the sly 1 widescreen patch didn't work (on cheats_ws) wich takes me to a new question.

Are cheats (all types) working on linux? can linux users try, and report back, would be much appreciated
Reply
#5
Have you enabled cheats?
Have you set the aspect ratio to 16:9?
Please post the full emulog after you observed the problem.
Reply
#6
Cheats do work on Linux. I personally use my own pnach files. However, I have not needed the PPA for awhile now, as I am using my own recently compiled version from a month ago, hence all my stuff, including cheats, is self contained in what would be the bin directory post compilation.

With system folders, you have to assign a superuser (sudo) status to access certain files in the /usr directory. But doing that with the PPA will identify you as "root" which is not a good way to run a Linux OS. The less root functions you use, the better.

To add, the git summary on the home page shows that someone has addressed this problem. However, Gregory will still need to merge it in the PPA.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#7
(08-21-2015, 01:06 AM)willkuer Wrote: Have you enabled cheats?
Have you set the aspect ratio to 16:9?
Please post the full emulog after you observed the problem.

(08-21-2015, 02:43 AM)DaTankAC Wrote: Cheats do work on Linux.  I personally use my own pnach files.  However, I have not needed the PPA for awhile now, as I am using my own recently compiled version from a month ago, hence all my stuff, including cheats, is self contained in what would be the bin directory post compilation.

With system folders, you have to assign a superuser (sudo) status to access certain files in the /usr directory.  But doing that with the PPA will identify you as "root" which is not a good way to run a Linux OS.  The less root functions you use, the better.

To add, the git summary on the home page shows that someone has addressed this problem.  However, Gregory will still need to merge it in the PPA.

I'm not gonig to run it on superuser, i've seen the git page i'll wait for gregory to update the ppa

Thanks
Reply
#8
Note that as of yesterday, this issue should be now fixed. Thanks turtleli! (and welcome! Smile )

Quote:For the install version on Linux, PCSX2 now searches for cheats in $HOME
instead of /usr. For the install version on Windows, PCSX2 now searches
for cheats in Documents/PCSX2 instead of the cheats directory where
PCSX2 is installed.

https://github.com/PCSX2/pcsx2/commit/55eebb5

Note that this should not have affected portable mode.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply




Users browsing this thread: 1 Guest(s)