Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ESC key causes PCSX2 to crash
#1
If I've already started a game, hitting the escape key causes the whole program to die. I get the following error in the console:

Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 13550 Bus error ./pcsx2

It's not a huge deal, but I'm curious if anyone else is experiencing this. I just have to make sure my settings are right before I start. It's a minor nusiance.
Reply

Sponsored links

#2
hm, I don't think I'm getting that issue on 0.9.6. Which game?
Reply
#3
It's any game. I think it might have something to do with the controller plugin. I'm using a wired Xbox 360 controller. If I set the xbox guide button to be any button, I get thet same error and crash, but right when I start the game. If I don't use that button, then I only get the error when I hit the ESC key.
Reply
#4
yeah, might be, I'm going to release another controller plugin but for now I can't reproduce the issue so can do nothing really
Reply
#5
(01-29-2011, 11:00 AM)blakekl Wrote: If I've already started a game, hitting the escape key causes the whole program to die. I get the following error in the console:

Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 13550 Bus error ./pcsx2

It's not a huge deal, but I'm curious if anyone else is experiencing this. I just have to make sure my settings are right before I start. It's a minor nusiance.


I'm having the exact same problem.

Also, I cant get MGS3 to work. The main screen loads fine, and I can create a new game but before the first FMV, the app crashes and returns error:
Offset 0x2900000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 10502 Segmentation fault ./pcsx2


when hitting ESC from BIOS i get:
Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 10976 Bus error ./pcsx2


I've tried every combination of speed, game and graphic options to no avail. If it matters, I'm trying to use a PS3 controller over bluetooth
Reply
#6
If you're getting it with a controller too, I'm almost certain it is an issue with the ZeroPAD plugin. We'll just have to wait for 0.9.7 and the new controller plugin. Smile
Reply




Users browsing this thread: 1 Guest(s)