Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFXII strange performance (WinXP vs Win7)
#1
hi guys, sorry if this is in the wrong section, didn't knew where to put it...

i just formatted my pc and did a clean install of both windows xp and windows 7 and notice a strange difference of performance

having the same exact configuration for FFXII (directx 9 for both) i always have 60 fps on windows xp but in certain situations i have around 50fps in windows 7, this situations are mainly in the menus, for example in this specific menu i get around 52fps in win7 and full 60fps in winXP

i tried turning off aero but that didn't help at all, directx 11 is even worse than 9 on win7...

does any one of you have an idea of where is the performance leaking too?
since its a clean install maybe you know of things i can deactivate on windows7 to increase the performance

thx in advance
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]
Reply

Sponsored links

#2
Maybe make sure you use the "high performance" power profile on your win7 control panel. Could be lots of things really.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
nop doesn't help, same performance
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]
Reply
#4
Make sure drivers are up to date.


What settings do you have anyway?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
of course they are, when i said that i did a clean install doesn't mean i didn't updated everything... in fact i think this decrease of performance already existed before the clean install
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]
Reply
#6
Usually Windows 7 is way faster than XP in gaming, in Pcsx2 is the same, I used to get 12 fps in clock tower in dx9 (xp) but 60fps in windows seven dx10 Laugh, in Xenosaga is the same Tongue
PC:
EVGA 600 +80 PSU
NVIDIA GTX 550ti EVGA 2GB VRAM
[Image: hj0zqy-4.png]
OS: Debian Stretch 64bits  Cool
OS: Windows 10 Home 
Reply
#7
Use DirectX 10, Don't use DirectX11 cause it's still in alpha stage.
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#8
i'm pretty sure the problem here is the OS... these fps drops in win7 happen when there is a lot of textures and sprites to render so its hitting the GPU... i think the problem might be some sort of feature of windows 7 that eats some graphic card resources

@ikazu: thats not the point, i know how to configure pcsx2 and in fact i have a rev build that doesn't have dx10 anymore, not just that but i'm comparing dx9 in both since windows xp doesn't have anything higher

some screenshots:

windows xp:
http://img2.pict.com/58/4b/86/3197923/0/ff12xp.png

windows 7 (same configurations):
http://img2.pict.com/e9/0f/a0/3197924/0/ff127.png

oh, and my configurations (only the relevant ones):
http://img2.pict.com/1e/32/18/3197965/0/config.png
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]
Reply
#9
Disable Allow 8-bit textures, doesn't really help in that game.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
Disable Allow 8-bit textures as Lady said, it's a huge FPS impact and i can't really notice any different having it on, expect for the huge fps drop =)
Reply




Users browsing this thread: 1 Guest(s)