Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS Drops randomly in Persona 3 FES
#1
Hey everyone,

I've been trying to run Persona 3 FES (On PCSX2 0.9.8), and while it generally runs fine, it randomly drops down to about 40 FPS occasionally.

Relevant Computer Specs
24 GB 1600 Mhz DDR3 Kingston HyperX RAM
ATI Radeon HD 5870
Intel Core i7 960 (3.2 GHz * 4 (8 thread))
Windows 7 64-bit ultimate
In case any Dual monitor issues are known, running 1 1920x1200, and 1 1920x1080.

Plugins
GSdx 4600 SSSE3 0.1.16 (Direct3D 11 and 9 software and hardware tested.)
LilyPad r4510 0.10.0 [lilypad-r4600]
SPU2-X r4600m 1.4.0 [spu2-x-r4600]
cdvdGigaherz (r4510) 0.8.0
All others are null drivers.

Settings
Automatic Gamefixes is on.

EmotionEngine Recomplier (EE Cache - Interpreter Only unchecked)
IOP Recompiler
EE/FPU Round Mode: Chop/Zero, Clamping Mode: Normal

VU0 microVU Recompiler
VU1 microVU Recompiler
Round Mode: Chop/Zero
Clamping Mode: Normal

Framelimiter not disabled. 100% Base, 50% slow motion, 200% Turbo.
Frame Skipping Disabled.
Synchronized MTGS / disable all GS output unchecked

Aspect Ratio Standard 4:3
Window Size 1280x960
Zoom 100.0

Speedhacks disabled (Note: have all tried enabling speedhacks with EE Cycle rate 2, INTC Spin Detection and Wait loop detection on, mVU flag Hack on. No difference)

Manual Game Fixes off. (Note: mentioned above Automatic are on)

Any advice?
Reply

Sponsored links

#2
What are the EE%/GS% at the top of the emulation window reading at when you get slowdowns? Do you get slowdowns when playing at normal (native 512x512) resolution?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
(07-17-2011, 07:53 AM)MyDreamName Wrote: What are the EE%/GS% at the top of the emulation window reading at when you get slowdowns? Do you get slowdowns when playing at normal (native 512x512) resolution?

EE: 37%
GS: 17%
However I've also had this been with 60 FPS.

Trying 512x512... Slowdowns occur as well.

Console contains no Errors.
No rhyme or reason for slowdown, seems to be random - Sometimes the beginning cinematics will be slow, sometimes they won't, for example.
Reply
#4
Update, this problem seems to occur in many games after some more experimentation (Persona 4, Disgaea 2, SRWOhmyGG, etc.). I'm guessing something is wrong with my configuration, but I'm unsure what. It doesn't seem to be a CPU issue, as it never uses more then 7% of my CPU.
Reply
#5
(07-21-2011, 05:30 AM)gralamin Wrote: Update, this problem seems to occur in many games after some more experimentation (Persona 4, Disgaea 2, SRWOhmyGG, etc.). I'm guessing something is wrong with my configuration, but I'm unsure what. It doesn't seem to be a CPU issue, as it never uses more then 7% of my CPU.

Try with the last svn, or the old 0.9.7, but is rly weird, i have tested the p3 and p4 games and they work just fine here.
Reply
#6
i have the same issue.

my spec:
Intel Core i5 430M
2GB DDR3 1333Mhz
Nvidia 320M 1GB.
Windows 7 32-bit ultimate SP1.

Settings
Automatic Gamefixes is on.

EmotionEngine:
Recomplier (EE Cache - Interpreter Only unchecked)

IOP:
Recompiler

EE/FPU Round Mode:
Chop/Zero

Clamping Mode:
None

VU0:
microVU Recompiler

VU1:
microVU Recompiler

Round Mode:
Chop/Zero

Clamping Mode:
None

Framelimiter:
enabled. 100% Base, 50% slow motion, 200% Turbo.

Frame Skipping:
Disabled.

Synchronized MTGS and disable all GS output:
unchecked

Aspect Ratio: Standard 4:3

Custom Window Size: 640x480

Zoom 100.0

Speedhacks: disable. (I have tried to turn on EE cyclerate level 2 and VU cycle stealing lvl.1, check all hack but leave enable fast CDVD as it not recommended, but no luck.)

Manual Game Fixes uncheck.

I've just installed windows 7 sp1, i thought it was the case, but even after i remove the pack, FPS still drops randomly, especially in AMV...
Reply
#7
The Core i5 430M is very weak. According to Wikipedia the mobile Arrandale i5 and i3 are identical, except for the TurboBoost. The low clock speed Arrandale (2.13, 2.26) is sold under i3 brand name and the higher is sold as i5. The i3 380 @ 2.53 Ghz and 390 @ 2.66 Ghz just appeared by the end of last year. My brother Dell Studio with an i5 450 runs GoW2 at 25 FPS while my desktop i3 530 runs it at 30 FPS. So getting frame drop is normal.

It is really weird that the topic creator got frame drop with his high end PC. This PC should runs most games well, even Shadow of the Colossus or Grand Thief Auto.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#8
(07-21-2011, 05:29 PM)Livy Wrote: The Core i5 430M is very weak. According to Wikipedia the mobile Arrandale i5 and i3 are identical, except for the TurboBoost. The low clock speed Arrandale (2.13, 2.26) is sold under i3 brand name and the higher is sold as i5. The i3 380 @ 2.53 Ghz and 390 @ 2.66 Ghz just appeared by the end of last year. My brother Dell Studio with an i5 450 runs GoW2 at 25 FPS while my desktop i3 530 runs it at 30 FPS. So getting frame drop is normal.

It is really weird that the topic creator got frame drop with his high end PC. This PC should runs most games well, even Shadow of the Colossus or Grand Thief Auto.

thank you.

i just test with my old pc spec:

1:
Intel core 2 duo e4600.
2GB DDR2 800Mhz
AMD HD 4650 1GB DDR2.
Windows 7 32-bit ultimate sp1.

and

2:
Intel Core i5 430M
2GB DDR3 1333Mhz
Nvidia 320M 1GB.
Windows 7 32-bit ultimate SP1.

same config with all speed hack enabled. (uncheck enable fast CDVD)

i got 60fps most of time in #1 and #2, but even with a higher potential, the #2 still have fps drops in the AMV. #1 didn't.
Reply
#9
(07-17-2011, 08:17 AM)gralamin Wrote: EE: 37%
GS: 17%
However I've also had this been with 60 FPS.

(07-17-2011, 07:53 AM)MyDreamName Wrote: What are the EE%/GS% at the top of the emulation window reading at when you get slowdowns?

This could've indicated where your problem was.

(07-21-2011, 06:45 PM)Thuong Luong Wrote: Nvidia 320M 1GB

This is weak. I'd wouldn't be surprised if that's your problem.

What is your internal resolution set to? Still default?
Reply
#10
The desktop CPU is superior than the laptop counterpart, even in lower brand name. You can check some benchmarks and see the Core 2 Duo E4600 is much more powerful than the i5 430M.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply




Users browsing this thread: 1 Guest(s)