Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failed loading MemoryCard from file [XP SOLUTION]
#1
Specs
Windows XP SP3

Problem
You just reorganised folders, or you just installed, then you get this message:

Failed loading MemoryCard from file: C:\wherever\pcsx2\memcards\Mcd001.ps2

You memcards folder name might also turn blue. (This is OK. It means Windows is compressing the folder/file. Change with Right-click > Properties > Advanced...)

[SOLUTION - XP]
(Optional) Backup with memcard files with mymc:
http://www.csclub.uwaterloo.ca:11068/mymc/index.html

The file path is too long.
C:\Documents and Settings\Name\Desktop\Games\EMULATION\Emulators\PS2\Blah\whatever\pcsx2-r1888

Moving it up a few folders will fix it. Simple.

[SOLUTION - Vista/Windows 7 (from the FAQ)]
Right click on pcsx2.exe and select 'Run as administrator' (Vista / Windows 7 only) and/or install PCSX2 on a folder you have rights to write (like My Documents)
Reply

Sponsored links

#2
you can also go to properties and check off "run as administrator" in vista/7 ( might say "eleveted privelages" one of the 2)
Reply
#3
or you can also open the emulator and point it to the correct memory card file..
[Image: 871087.png]

*Mio sees a ghost for the first time*
Mio: Aaaaaaah!! x_x
Seriously, the way she acts, you'd think she grew up with ghosts.
Reply
#4
(07-22-2010, 12:19 PM)RenShijo-Kun Wrote: or you can also open the emulator and point it to the correct memory card file..

someone's not looked at the options... you CAN'T change what the names are in 0.9.7 they are set and the only way is to edit the pcsx2 ini manually. (which is NOT recomended)
Reply
#5
About the XP solution...
On the old and the new gui I pointed a card with really long path(40 more letters compared to your example)and on both versions,the card was loaded normally without any problems
Reply
#6
(07-22-2010, 08:05 PM)vsub Wrote: About the XP solution...
On the old and the new gui I pointed a card with really long path(40 more letters compared to your example)and on both versions,the card was loaded normally without any problems
I could replicate the problem with all the versions I had. I have 0.9.6, 0.9.7 and 1888.

I had them in "C:\Documents and Settings\Username\Desktop\Games\EMULATION\Emulators" with "PS2 - " prefixes on the folders, like:

C:\Documents and Settings\Username\Desktop\Games\EMULATION\Emulators\PS2 - Pcsx2_0.9.7

Then I made an "Emulators\PS2" folder and put them inside to organise them, which was when the error started appearing. Pointing to the memcard location in options didn't fix it, and neither did deleting .ini's.
Reply
#7
If the path for the card in the ini is non-existing path then that error appear.
I have pcsx2 1504,1888,2186 and 3443

BTW my testing path was
D:\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\New Folder\memcards
Reply
#8
its enough to put the pcsx2 folder in D:/ or just My Documents...no need for these long paths
I'm inactive on this, dedicating most of my time to osu!
Reply




Users browsing this thread: 1 Guest(s)