Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games running slow?
#1
Question 
Hi I am trying to play Final Fantasy X and it says its getting around 30fps maybe 26fps at the lowest however it seems to be playing the game at like half speed or something the graphics move fine but are slower then the game really is and the sound is slowed down. In the window title it says its only using 50% gpu and 30% cpu so i'm not sure what is going on. Here are my system specs:

Intel Pentium D 915 2.8ghz dualcore
2gb ram 533mhz ddr2
nVidia 9800 GTX+ 512mb
Reply

Sponsored links

#2
Full speed for PS2 games is 50fps PAL and 60fps NTSC, any lower than that and you get slow speeds. You have a slow CPU but you should be getting higher speed, try the latest beta and show us your PCSX2 and plugin settings so we can help better.
http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I just tried the beta with the same results maybe a few more fps but not noticable. I'm not sure how to show you all my settings.
Reply
#4
Post some screenshots.
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#5
I made one big screen shot hope I got all the important windows Tongue2 I was running it as windows small but someone told me to try full screen so it hasn't been at 1680x1050 the entire time.

[Image: 62250235.png]
Reply
#6
Tick only the native option. Disable all other options. Use MicroVU0 and microVU1. As they will help a lot in games. And if u think, u need more speed, tick more options in speedhacks, like X2 or move the VU Cycle Stealing to Moderate or slight.
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#7
Disable "allow 8-bit textures" in GSdx, change the renderer to Direct3D10 (Hardware), untick the "native" check if you want as you have a good enough graphics card and it can actually be slower sometimes when you're CPU limited.

Do not activate microVU because it will probably be just slower, enable the "x2 cycle rate" and "idle Loops fast-forward" speedhacks as well as setting "VU cycle stealing" to 'slight'. I can't see the sound plugin but try setting it to SPU2-X and ticking the "disable effects processing" option if you aren't already using that.

Unfortunately as mentioned before you have a slow CPU and that's probably as good as it will go.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
Yeah tried all that the microVU did make it go slower. I know that this has to emulate the ARM proccessor but you would think a dual 2.8ghz would be able to handle a 700mhz arm but guess not lol. It's weird that it jsut plays the game slow instead of choppy and only says its using 30% of my cpu.

EDIT: Just checked when the emu window says 30% cpu it's really 79% in speedfan so guess it is my cpu.
Reply
#9
I believe the cpu percentage the emu shows you is not load on your cpu, but the percentage of "full speed" you are currently achieving. 100% = full speed. So if you constantly only get ~30% you need more than 3 times the horsepower to make your game "full speed".
Reply
#10
The CPU% shown in the GS window is about the GS thread of PCSX2, i.e. the load of the graphics thread. So this shows you how much load there is on your graphics card and not your CPU.
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)