Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to fix Grandia III random crashing problem(On battle scene)
#1
I already search in forum for this problem but i can't find the way to fix it.

I use PCSX2 0.96 / GSdx 845(MSVC 15.00,SSE41 )0.1.9

(My Cpu is Q8200 @ 2.33 GHz )
Reply

Sponsored links

#2
Any speedhacks enabled? If yes, turn the CycleRate hacks off please.
| i7 860 2.8@4ghz | Scythe Mugen 2 Rev.B | Asus Maximus Formula III | G.Skill Ripjaws 4 Gigabyte | 570 GTX AMP! | Enermax 720w PSU | X-Fi Titan | OCZ Vertex 120 GB |
Reply
#3
No such crashes are known. Go back to default config and try that again.
Only if it continues to crash report back (possibly how to reproduce it as well).
Reply
#4
its unbelievable man, Problem while using :
GSdx 845(MSVC 15.00,SSE41 )0.1.9


Must ask From Moderator
Reply
#5
can it be that's my bios is too old ?
i try for ZeroGs 0.97.1 Plugin too but it's make the same problem.
(look like game will crash when one of character on battle scene try to use some of skill/magic/item(there show skill name before game crash))

My bios is USA v01.6(07/02/2002)

(I can play FF XII with no problem.)
Reply
#6
(03-22-2009, 06:05 AM)cdaz Wrote: can it be that's my bios is too old ?
i try for ZeroGs 0.97.1 Plugin too but it's make the same problem.
(look like game will crash when one of character on battle scene try to use some of skill/magic/item(there show skill name before game crash))

My bios is USA v01.6(07/02/2002)

(I can play FF XII with no problem.)

Nothing to do with BIOS. Have you tried disabling speedhack? Also you can try re-rip your ISO. I had the same problem back in the PSX decade with castlevania, whenever I open the menu it crashes. And I ended up finding it was my CD-ROM's fault.
Reply
#7
(03-21-2009, 03:45 PM)cdaz Wrote: I already search in forum for this problem but i can't find the way to fix it.

I use PCSX2 0.96 / GSdx 845(MSVC 15.00,SSE41 )0.1.9

(My Cpu is Q8200 @ 2.33 GHz )


Huh! I used to have the same issue (random crashes) in previous versions up until the official 0.9.6 came out; but ever since 0.9.6 SVN 791, the random crashing has ceased. Yes, I do have 3x Cycle Rate (and the three boxes on the right side) and never had a problem since. Yes, I should probably have that set to 1.5 or 2, but for the sake of the game's music, I keep it at 3x so the music will be able to catch up to the game. Speed hacks should be used with caution, because it can cause in-game stability issues and end up crashing PCSX2. As mentioned before, start out from 1.5, then 2 and then 3 and see which one works best for you. Speed hacks create shaky cutscenes; either change the hack to 1.5/2x or skip them since the game will likely crash at the cutscenes' end.
Reply
#8
thankyou i will try to re-rip my ISO.
(I'm already turn off all Speedhack now)
Reply
#9
Grandia III only crashed for me with cycleRate hax 2x / 3x.

without np.
| i7 860 2.8@4ghz | Scythe Mugen 2 Rev.B | Asus Maximus Formula III | G.Skill Ripjaws 4 Gigabyte | 570 GTX AMP! | Enermax 720w PSU | X-Fi Titan | OCZ Vertex 120 GB |
Reply
#10
I'm a new arrival here and have been having the same problem with crashing at some point in battle-scenes. I've included what I think are the relevant hardware details in my sig, and I've been using PCSX2 0.9.6 with GSdx and all the other the plug-ins configured as (I think) they should be. And the latest DirectX redist. Oh, I'm using Windows XP, I'll add that to my sig if I remember, as it is probably very relevant (not just because my gfx card is DX10/SM4.0 capable with that, but only DX9/SM3.0 with XP of course).

It also froze at the end of the scene in the starting village at the end of the movie when a girl (who wants to be kidnapped) is held up, but I got around that by skipping the movie by hitting 'Select'.

I have been using 1.5x EE rate (along with the other three ticks on the right-side of that box) as that seemed the ideal combination which provided smooth movies and maximum framerate. I turned them all off (and even set the Advanced settings to 'Extra + Preserve Sign') for the end of movie crash but that didn't help, but that one could be bypassed.

The problem with the battle-scene seems to happen with big encounters-- six or so opponents, where I tend to deploy area-effect moves or magic. I don't know whether it is using those moves/magic during it is the cause as the error doesn't occur until the battle ends. Maybe EE rate or some sync speed-fix causing problems? I may be answering my own questions here. I should try playing with them all disabled (though it could be painfully slow).

Or I could try a beta. SVN 791? Since this is the only game I am currently wanting to play on it, I might give that a shot. So many options (beta version, disabling options, overclocking somewhat more). Overclocking further is certainly an option as I have a Thermalright XP-90C heatsink on my CPU, and in normal use the heatsink fan hardly runs.

I think I'll start with disabling all the speed-hacks as that is the easiest to do, even if it may slow things down a bit.

By the way, don't take any of the above as criticism of the great work you guys have done: I know how complex even ZX Spectrum emulation is (especially once you want to accurately do the R-register and correct screen-timing and memory-contention), so what you've done with the PS2 is nothing short of miraculous.
CPU: Athlon 64 X2 4400+ (2.2GHz @ solid 2.53GHz)
GPU: nVidia GeForce 8800GTS 640MB (not currently O/C)
Memory: 2GB DDR400 (2x 1GB @ DDR422 2.5-3-2)
Reply




Users browsing this thread: 1 Guest(s)