Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Huge slowdown in previously working games
#1
Hi:

I've allready posted about this, when the game KOF MI 2 did not work fast enough to be played I thought my cpu is not fast enough. But now I'm thinking something is wrong with either my configurations or my pc or something.

Here is the thing I've recently installed win 7 x64 7100 (I previously had Win XP 32 bits SP3). But the thing is the emulator, instead of going faster it goes slower. I don't know why. It started with SRW MX whenever there were more than a few units on the map the game would seriously slow down to about 20 to 35 fps.

Now I've tried Devil May Cry one that I had seen people getting good speeds with setups similar to mine but to my surprise I again got about 25 to 40 fps which makes the game unplayable.

So I've decided to try a game that I started from start to finish with no problems and with exellent speeds (60 fps easy) : FFX (when I had XP). Again huge 25 to 35 fps slowdowns.

Now when I said I've tried I mean every configuration of speedhacks and they at most add about 4 or 5 fps. And I have tried both DX9 and DX10 modes.

Does anyone have any idea what this could be or how to fix it...
Because I love Win 7, everything I have tried so far works great and really fast (I would dare say faster than XP most of time including PC Games like Prototype) so I won't change it back. But I would like to know if there is anyway around this so I could maybe play PS2 games in the PC again.

Well thanks for any help.
My Computer: Intel i7 870 @ 2.93 Ghz. XForce Ati Radeon 5870 with 1 Gb RAM. 6 GB DDR3 1333 Mhz RAM.
Reply

Sponsored links

#2
Eh well try updating drivers disabling aero... make sure pcsx2 is running on 2 cores try changing the affinity of it to run on the last 2 cores only actually, using the high performance power profile... dont know really new windows installation cant really expect everything to work the same :/
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
This almost definitely sounds like video card driver problems. I'm not familiar enough with Win7 to help you troubleshoot/find/upgrade drivers or whatever, but I can at least tell you that it's a strong (very!) likeliness that your video card drivers are killing you here.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#4
Hi:

About disabling Aero, I'll try that and I'll also try with High Performance Power settings. Thank you. Oh and I realize what I'm asking its kind of hard.

About what Air said. Yes I thought of that too. When I installed Win7 I downloaded the latest 64bit drivers for my card from the nvidia site. And for example as soon as I start FFX where I see only Tidus it works ok and progressively slows down when more things enter the screen. How would I approach this? Just wait for new video drivers?

Thank you I'll try the above things tonight and report back.

Bye

pd: How do I get PCSX2 to run on the last two cores only?
My Computer: Intel i7 870 @ 2.93 Ghz. XForce Ati Radeon 5870 with 1 Gb RAM. 6 GB DDR3 1333 Mhz RAM.
Reply
#5
Open task manager , make sure pcsx2 is running.
Right click on pcsx2 executable and click on set affinity.
Reply
#6
[Image: select.jpg]
go to taskmanager and right click on a process
then select "set affinity"

[Image: changez.jpg]
then select wich cores to run the process
to avoid confusion with core names
core0 is the 1st core, core1 is the 2nd and so on
without software this has to be done for all by hand every time you restart computer/laptop
[Image: 1454055.png]
Reply
#7
(09-01-2009, 11:54 AM)ChronicNL Wrote: [Image: select.jpg]
go to taskmanager and right click on a process
then select "set affinity"

[Image: changez.jpg]
then select wich cores to run the process
to avoid confusion with core names
core0 is the 1st core, core1 is the 2nd and so on
without software this has to be done for all by hand every time you restart computer/laptop

Thank you. Without what software are you talking about?
My Computer: Intel i7 870 @ 2.93 Ghz. XForce Ati Radeon 5870 with 1 Gb RAM. 6 GB DDR3 1333 Mhz RAM.
Reply
#8
well i dont know any software to do it for you
so you will have to manually unselect all processes for those cores EVERY TIME you restart your comp
its horrible lol
[Image: 1454055.png]
Reply
#9
(09-01-2009, 11:39 AM)aarelovich Wrote: About what Air said. Yes I thought of that too. When I installed Win7 I downloaded the latest 64bit drivers for my card from the nvidia site. And for example as soon as I start FFX where I see only Tidus it works ok and progressively slows down when more things enter the screen. How would I approach this? Just wait for new video drivers?

Ehr last sets of drivers are exactly the most stable try some 185 or 186 ones. Even 182 ones would be the most stable if you dont mind not having WDDM 1.1
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
185.85 works great, i personally use a modified version of it called DOX 185.85 (optimized for laptops)
[Image: 1454055.png]
Reply




Users browsing this thread: 1 Guest(s)