Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Huge speed drop with 1.0
#1
Surprisingly I get a major speed drop when using version 1.0.
When I downloaded it and tried to run it I got the message "msvcr100.dll not found" which suprised me since 0.9.8 starts normally. I then installed MS VC++ 2010 x86 and version 1.0 starts but it is very slow. Annoyingly 0.9.8 also became slow afterwards too so I had to uninstall VC++ which fixed 0.9.8 but of course 1.0 complains again about the missing DLL.

Any Ideas what might be the issue? I'd really like to use version 1.0 since it got some specific improvements for the game I'm currently playing.

My computer specs if this might be of any importance:
Windows 7 x64
i5 @3.6 GhZ Sandy Bridge
Geforce GTX 550 TI
4GB DDR3 RAM
Reply

Sponsored links

#2
That is weird. The issue is definitely not with the redist files so try to find out what could cause this behavior a bit more.
Reply
#3
update direct X
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#4
I don't see the problem here. PCSX2 0.9.8 is slower for me. 1.0 runs fine.
Well, what do you mean by slow. Is the FPS during Gameplay slow or the GUI?

If its the FPS, then try copying the inis/ folder of 0.9.8 to 1.0.

warWeeny Wrote:update direct X

That won't help, because the problem is with msvcr100.dll which is Visual C++ Runtime DLL. Also, I don't think PCSX2 leaves you until you have the latest June 2010 Redistributable.

*Yay! 1400th Post. Cool
[Image: recodersignature2.png]
Reply
#5
Pcsx2 0.98 was compiled using VS2008, hence it needs the VS2008 runtime. The nightly builds and the 1.0 release are compiled using VS2010, so they needd the VS2010 runtime.

The Pcsx2 installer comes bundled with VS2010 runtime SP1, but Pcsx2 also works with the pre-SP1 redistributable. You can download the older non-SP1 VS2010 runtime and see if it doesn't cause slowdowns as the SP1 runtime.

Also, nothing is preventing anyone from compiling the latest (or 1.0 release) source code of Pcsx2 using VS2008 (even express, which is free for anyone to download and use), and this build will not need the VS2010 runtime. That being said, I don't think any of the devs has VS2008 installed anymore, but someone who still uses VS2008 might be kind enough and send you a recent build privately.

All that being said though, it seems to me like an issue with your system doesn't liking VS2010 runtime. That's a Microsoft product which the Pcsx2 team as no control over, and so I don't think we can change anything at the source code to fix this issue. Also AFAIK, it's the first time we hear of this issue, so I don't think we have existing known workarounds beyond what I've just suggested above.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#6
Stupid suggestion...while MS VC++ 2010 is installed and you also use pcsx2 1.0.0 try downloading the pcsx2 0.9.8 binary,place the pcsx2-r4600 file inside the pcsx2 1.0.0,start that version and see if there is any notable differences.

Also I think I had some weird problem way back when I was updating from one major version to other(pcsx2 was working slower after the update).
After deleting(I don't remember which one was the case)the .nvm and .mec files from the bios folder or\and deleting the pcsx2 settings(you can use pcsx2=>Config=>Clear all settings),pcsx2 started to work faster like before

PS.Those .mec and .nvm files are created automatically when you start pcsx2(and a game or the bios)

Edit:btw did you restart the pc after installing the MS VC++ 2010?
It's not really needed but just to check if will make any difference
Reply
#7
(08-06-2012, 06:16 PM)avih Wrote: The Pcsx2 installer comes bundled with VS2010 runtime SP1, but Pcsx2 also works with the pre-SP1 redistributable. You can download the older non-SP1 VS2010 runtime and see if it doesn't cause slowdowns as the SP1 runtime.

Thanks, I wasn't aware that there are two different versions. I believe I had the non-SP1 installed, will try SP1 now.

edit:
That was it. After installing the SP1 VS2010 everything works like a charm. Thanks!
Reply
#8
I don't think we've seen VC runtime issues with SP1/Non-SP1 versions before, so thanks for letting us know how it got solved.

Also, SP1 was released for a reason, so you might bumped into one of the bugs of the older runtime release on your system.. (on my system both versions performed the same with pcsx2).
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#9
the VS2010 non sp1 runtime has several performance related bugs that were fixed in SP1

Code:
C++ runtime

    SSE2 instructions generated when /arch:SSE is specified
    Missing destructor calls when optimization is enabled
    Code generation bug in x64 C++ compiler (optimizer)
    C++ compiler generates incorrect movups instructions iso movss
    Optimizer bug (/Og) with the 64-bit 2010 Beta 2 compiler.
    Visual Studio 2010 VC++ Concurrent Runtime libraries leak memory
    concurrent_queue causes crash
    Memory leaks reported when using simple parallel_for code
    ftell returns negative value for UTF-8 files opened with textmode and ccs
    vector::erase returns incompatible iterator in debug build
    tr1:regex has different behavior between vs2008 and vs2010 on some regular expression
    inserting in a std::vector of std::string causes memory leak
    CRecordset/DoFieldExchange not working properly in Visual Studio 2010
Reply
#10
OP i had same problem as you yesterday... i was using SNV 0.9.9 3547 and then i installed 1.0 FPS was much lower in all games and i am sure i was using all settings same in both versions.

Then in the end i uninstalled version 1.0 and installed it again, after that it works gr8.

So try reinstalling 1.0 and see if that solves your problems.
Reply




Users browsing this thread: 1 Guest(s)