Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is there really nothing that can be done about motion blur?
#1
I'm talking about the SEVERE ghosting that affects certain games, specially Atlus games such as Nocturne, Digital Devil Saga and supposedly Persona 4 (I didn't play this one).

I recall some people saying that old SVN revisions managed to eliminate or reduce the ghosting, so maybe this problem is not impossible to fix?

I tried messing with the texture coordinate offset (which supposedly fix ghosting issues) but had no luck so far.

Sponsored links

#2
(02-23-2014, 03:28 AM)Draconic Seed Wrote: I'm talking about the SEVERE ghosting that affects certain games, specially Atlus games such as Nocturne, Digital Devil Saga and supposedly Persona 4 (I didn't play this one).

I recall some people saying that old SVN revisions managed to eliminate or reduce the ghosting, so maybe this problem is not impossible to fix?

I tried messing with the texture coordinate offset (which supposedly fix ghosting issues) but had no luck so far.

Did you try software mode (F9)
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
#3
Press F9 during gameplay to start software mode. the game will run slower but it will correct most emulation problems.
also u can disable speedhacks to see if that makes any difference.inappropriete speedhacks sometimes creates problems.especially enabling mtvu hack on a dual core cpu.
if the problem still remains then report back with your pc specs and pcsx2 settings.
[Image: lhljdGn.png]
My Steam Profile
Intel i5 3450 @ 3.1ghz~3.5ghz | Nvidia Gtx 980ti 6GB | Corsair Vengence 16gb DDR3 | WD Blue 1tb + Black 2tb hdd | Samsung 850 Evo 250gb SSD | Windows 10 pro

#4
Guys, software mode will be the same i the game features motion blur, like Persona 4. The lower resolution of software mode masks it a bit, but you lose a lot of resolution. At the moment I don't know any way to disable motion blur in Persona 4.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
#5
Skipdraw might also resolve the problem.

Try numbers 1-10.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
#6
I tried everything, software mode, skipdraw, speedhacks, nothing works.

Using "bob tff" interpolation together with a setting in my TV that creates more frames to make movement smoother seems to reduce the ghosting a little, but it's far from ideal.

As awesome as PCSX2 is right now, I hope the developers will make an effort to solve this issue in the future, it's really annoying. There are certain 30 fps games on PS3 that I can't play for the same reason: the heavy ghosting hurts my eyes and gives me a big headache.

Accidentally, I found a fix for another issue in SMT Nocturne: if you check "alpha stencil" under GSDX hacks, the map will be displayed properly (curiously, the map was displayed properly in version 1.0.0, and there was no alpha stencil checkbox).
#7
I was just thinking about this subject myself when I was playing FFX. I noticed some ghosting while playing but while I didn't mind that too much, one thing that irritated my eye was the motion blur of the background when you move in FFX. It hurts my eyes because of the constant refocusing on the background everytime I move in FFX. I noticed that it goes way if tab(set at 200%) or f4 is pressed.

I was wondering if there is anyway to get rid of this background motion blur similar to how Kingdom Hearts had a cheat to make the game much smoother.

As I was reading up on the subject, I was wondering if it is possible to do something like what Mame did with Blackframe insertion.

Again I know doing this stuff is extremely hard and time consuming(as a working man myself) and not something that is easily added with a simple suggestion, I was just asking if it is even possible to do on PCSX2.
#8
(02-24-2014, 06:17 PM)maguss Wrote: I was just thinking about this subject myself when I was playing FFX. I noticed some ghosting while playing but while I didn't mind that too much, one thing that irritated my eye was the motion blur of the background when you move in FFX. It hurts my eyes because of the constant refocusing on the background everytime I move in FFX. I noticed that it goes way if tab(set at 200%) or f4 is pressed.

I was wondering if there is anyway to get rid of this background motion blur similar to how Kingdom Hearts had a cheat to make the game much smoother.

As I was reading up on the subject, I was wondering if it is possible to do something like what Mame did with Blackframe insertion.

Again I know doing this stuff is extremely hard and time consuming(as a working man myself) and not something that is easily added with a simple suggestion, I was just asking if it is even possible to do on PCSX2.
Hard to say when it's an ingame feature . In FFX's case, this ghosting effect was originally hardcoded into the game. You could remove it in pcsx2 using skipdraw hack, though.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#9
I'm not familiar with those games, but it sounds like interlacing.

Interlacing is a mode of video output for old CRT TVs, and some PS2 games only output interlaced output. To make it look good on a "normal" progressive display (like computer monitors or new TVs), it has to be deinterlaced. There's no perfect deinterlace, though it can get close to perfect with advanced deinterlace algorithms - new TVs have them, but PCSX2 doesn't.

PCSX2, or rather GSdx, can deinterlace in one of few simple methods: blend, bob or weave. None of them is perfect and each has its own type of artifacts. Blend creates ghosting, weave shows as comb effect (horizontal lines) and bob makes the image shake. If the field order is incorrect (top/bottom field first) then the image is also distorted or jumps forward/backward quickly - on top of the mentioned side effects.

There's nothing to do about that - it's just how the game outputs its video. Other than trying all the deinterlace modes (F5 cycles through them) and pick what looks best for you, there's not much which can be done about it. I personally prefer bob since it's the closest to how it looks on a CRT TV, though the default is blend - which does create ghosting.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
#10
(02-24-2014, 06:56 PM)avih Wrote: I'm not familiar with those games, but it sounds like interlacing.

Interlacing is a mode of video output for old CRT TVs, and some PS2 games only output interlaced output. To make it look good on a "normal" progressive display (like computer monitors or new TVs), it has to be deinterlaced. There's no perfect deinterlace, though it can get close to perfect with advanced deinterlace algorithms - new TVs have them, but PCSX2 doesn't.

PCSX2, or rather GSdx, can deinterlace in one of few simple methods: blend, bob or weave. None of them is perfect and each has its own type of artifacts. Blend creates ghosting, weave shows as comb effect (horizontal lines) and bob makes the image shake. If the field order is incorrect (top/bottom field first) then the image is also distorted or jumps forward/backward quickly - on top of the mentioned side effects.

There's nothing to do about that - it's just how the game outputs its video. Other than trying all the deinterlace modes (F5 cycles through them) and pick what looks best for you, there's not much which can be done about it. I personally prefer bob since it's the closest to how it looks on a CRT TV, though the default is blend - which does create ghosting.

Thanks for the information (even if your post is a bit of a downer, lol).

I haven't given up yet. Searching this forum I found this thread, in which the guy claims to have disabled the blur effect with a .pnach patch, so maybe, just MAYBE (fingers crossed), the same can be done for Atlus games as well.

Is there any thread here where one can make requests for .pnach patches? Maybe some kind soul could help.




Users browsing this thread: 1 Guest(s)