Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 FM FPS/Slow Motion problems
#1
I did the "60 fps hack" from Here. I got a good chance in FPS, after that and messing around with my Plugin settings, ect.

But I'm still feeling like I'm playing in Slow-Motion. Not just general lag, but the game feels like it's running in SLOW-MOTION. Not just general FPS, literally slo-mo.

Even during fights I'm reading at 60 FPS. But it still feels pretty slow-motion, even when I defeat the enemy, it speeds up tons.

I could easily play it, but the slow-motion is soo annoying.

Even during those really nice looking cutscenes (even the opening cutscene, which looks amazing in my opinion) runs in maximum FPS silky smooth. So I was wondering if it had to do with that weird "Slow Motion Adjust" option in the GS settings (which is at 50% atm). Or just my computer specs.

EDIT: I also wouldn't worry about it too much if I hadn't played KH2 on the my actual PS2. I run regularly on PS2, and run in almost slow-motion on PCSX2 in FM.

Running PCSX2 0.9.8

Pentium® Dual-Core CPU E5800 @ 3.20GHz (2 CPUs), ~3.2GHz

Intel® G45/G43 Express Chipset ( It's probably because of my graphics card)

Windows 7 (x86)

According the thread that I linked, I'm pretty sure I'm not the only one with this problem.
Reply

Sponsored links

#2
If you're using that "hack" and only getting 60fps (according to the title bar) then you missed a step.

KH2 normally runs at 30FPS (with a 60hz refresh rate), to make the game run in 60fps you have to do two things.

1. Trick the game into slowing to half speed. (the game still runs at 30FPS at 60hz refresh, but it's playing half as fast)

2. Make the game play twice as fast. (the game will this display 60fps at a 120hz refresh rate, doubling the previous step and restoring the game to full speed)

You're missing the second step, you must manually set the frame rate to 120 and hope your PC can run the game fast enough to reach if. If your PC can't hit 120hz (literally emulating the PS2 twice over) you will only have the game slow down.
[Image: 2748844.png]
Reply
#3
The "cheat" enabled is the "//Half game speed" one that you're told to enable in the "60 fps hack" thread

[Image: b4au4z.png]

Here are the settings

[Image: f3g6jn.png]
Reply
#4
Your hardware is too weak to double the fps;p. The point of applying slowdown cheat and increasing frame limiter is to smooth animations, not to speed up the game. If you can't even run the game at full speed with default settings it's surely not for you.

At most you could use the opposite, apply speed up cheat(exactly same adress, just different value;p) and decrease frame limiter - that would speed the game up(and made the actual animations more choppy), but it's not worth it since you aren't soo far from actual full fps either;]. It better to lack a few fps than deal with the bugs caused by such methods;p.
Reply
#5
You're only hitting 56fps, either the 200% setting isn't "sticking", or your PC isn't capable of hitting higher. In which case, yes your integrated graphics are the cause. About the only options left to you would be using native or sub-native resolution to see if you could get it a bit faster, but I doubt you'd ever be able to hit the required 120fps for the trick to do you any good.
[Image: 2748844.png]
Reply
#6
(06-19-2013, 12:50 AM)miseru99 Wrote: Your hardware is too weak to double the fps;p. The point of applying slowdown cheat and increasing frame limiter is to smooth animations, not to speed up the game. If you can't even run the game at full speed with default settings it's surely not for you.

At most you could use the opposite, apply speed up cheat(exactly same adress, just different value;p) and decrease frame limiter - that would speed the game up(and made the actual animations more choppy), but it's not worth it since you aren't soo far from actual full fps either;]. It better to lack a few fps than deal with the bugs caused by such methods;p.

What is the cheat for the speed up cheat, and where is frame limiter?
Reply
#7
(06-18-2013, 11:56 PM)Fayde Wrote: Running PCSX2 0.9.8

Why?
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply
#8
(06-19-2013, 01:03 AM)Tyestor Wrote: Why?

Not important :/
Reply
#9
Well, it sort of is. You're running a very outdated version of PCSX2 that isn't even supported anymore.
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply
#10
(06-19-2013, 01:11 AM)Tyestor Wrote: Well, it sort of is. You're running a very outdated version of PCSX2 that isn't even supported anymore.

Well the versions I see people running 60 FPS on is from 2 years ago. Could it truly be because of an outdated version?
Reply




Users browsing this thread: 1 Guest(s)