Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS...
#1
Hi... Im new here... I have tried playing only one game on this emulator... Which is GTA Liberty City Stories (iso format located in one of my hard drives) During cutscenes, the FPS is averaging at about 14 fps... During gameplay, depending on where the character is looking at.... On the floor 60 fps, towards the sky 60 fps, towards a building 37 fps, towards a jungle full of trees 18 fps...

Here is my PC Specs...

Windows XP Home Edition SP3
Pentium® Dual-Core CPU E5200 @ 2.50GHz (x2)
Kingston 2GB of RAM
ATI Radeon HD 4670 - 512 MB Memory GDDR3
300 GB Hard Drive ( Divided into 3 local disks C , E , and F )

Here is the PCSX2 v0.9.6 configuration...

GSdx 890 (MSVC 15.00, SSSE3) 0.1.14
SPU2-X 1.1.0
LilyPad 0.9.9
Linuz Iso CDVD 0.8.0
DEV9null Driver 0.3.0
USBnull Driver 0.5.0
FWnull Driver 0.4.0

Cpu config
- Everything on the left is checked
- Frame (Limit selected)
- Custom FPS Limit = 60
- Everything else is zero

SpeedHacks
- Use x1.5 Cycle Rate
- Everything on the right is checked

Advanced Options
EE Recs
- Chop / Zero
- Clamp mode none
- Flush to Zero
- Denormals are Zero

VU Recs
- similar to EE Recs

How can I improve the fps??
Reply

Sponsored links

#2
How often is the CPU usage (the one thats on the upper right corner of the emu window) at +90%?
Reply
#3
(09-01-2009, 07:04 AM)mackoyski Wrote: How often is the CPU usage (the one thats on the upper right corner of the emu window) at +90%?

It is all the time 99%...
Reply
#4
In that case try to disable Vsync if you have it enabled and check the "native" option in GSdx settings, this might be one of the games that gets a big boost from DX10... also try using the latest beta and play with the "VU cycle stealing" speedhack on it setting it to moderate for example, and also updating your GSdx might help.

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
(09-01-2009, 07:46 AM)Shadow Lady Wrote: In that case try to disable Vsync if you have it enabled and check the "native" option in GSdx settings, this might be one of the games that gets a big boost from DX10... also try using the latest beta and play with the "VU cycle stealing" speedhack on it setting it to moderate for example, and also updating your GSdx might help.

http://forums.pcsx2.net/thread-3716.html

Im using Windows XP.... I cant have Direct X10...
Reply
#6
The latest version of GSDX (1650) provides a great boost compared to 890.

http://pcsx2.dyndns.org/index.php#GSdx

IMO, the HD 4670 might be the one that's causing the slowdown.
Reply
#7
I am using GSdx 890 (MSVC 15.00, SSSE3) 0.1.14...
I have disabled the "wait vsync" option and enabled the Native option... No difference...
Reply
#8
(09-01-2009, 08:00 AM)mackoyski Wrote: The latest version of GSDX (1650) provides a great boost compared to 890.

http://pcsx2.dyndns.org/index.php#GSdx

IMO, the HD 4670 might be the one that's causing the slowdown.

I have installed the GSDX (1650)... When i press run cd/dvd, it says i need to update my directx... When i click on ok, it says pcsx2 will now close, i clicked on ok again and then the pcsx2 becomes not responding... How do i update my directx manually?
Reply
#9
http://www.microsoft.com/downloads/detai...laylang=en

download the dxwebsetup and run it.

To be able to use recent GSDX versions you also need to install vc++ redistributable 10

http://pcsx2.dyndns.org/vc10/vcredist_x86.exe
Reply
#10
(09-01-2009, 08:13 AM)mackoyski Wrote: http://www.microsoft.com/downloads/detai...laylang=en

download the dxwebsetup and run it.

To be able to use recent GSDX versions you also need to install vc++ redistributable 10

http://pcsx2.dyndns.org/vc10/vcredist_x86.exe

I have done updating my directx... It works now with the GSDX (1650) but i still get the same fps... I have also installed the vcredist_x86... Still the same...
Reply




Users browsing this thread: 1 Guest(s)